It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crash on commit

I get bugsplat error after I try to commit. Can someone help me with this?

Is something I can fix or I have to wait for a SourceTree patch?

16 answers

Hi Ana,

1. I was not able to reproduce the error again. When I clicked on commit, Sourcetree would close instantly and open the bugsplat screen. I sent the error files, I was able to upload the temp file to mega but there was also an XML that I wasn't able to find. I didn't take a screenshot.

2. I'm using Windows 10

3. Sourcetree 3.2.6

4. I didn't get any errors beside that.

After being unable to fix this error, I installed Github Desktop and was able to make a commit. Today I tried to commit some other changes through Sourcetree and it went through as usual.

So it's resolved but I'm not sure why.

Thanks for the response and have a nice day! :)

Hi,

I'm getting the same problem of SourceTree crashing when I click commit.

I'm using Windows 10 and Sourcetree v3.2.6

I can change branches, fetch branches and pull down updates to branches.

sourcetree.PNG

 

bugsplat.PNG

AboutSourcetree.PNG

Click the link

bit bucket issue free versions 

download relavent version,

for windows 10, download 3.1.3, and run that exe file..issue will be fixed (smile)

Like # people like this

Problem solved,after follow above steps.

After uninstalled Source Tree 3.2.6, and installed the Source Tree 3.1.3, problem solved. Succeed when commit and push.

I think the crash caused by global git mercurial username and email that hasn't been configured. Because previously at 3.2.6 version my username and email not appear in the commit box, but after I installed the 3.1.3 version source tree prompts message box to confirm my username and email for git mercurial username and email. After that my username and email appear in the commit box. It works perfectly fine now.

 

Thanks Phani Kumar for the suggestions.

 

Another thread with same issue : https://community.atlassian.com/t5/Sourcetree-questions/Crash-on-commit/qaq-p/42492

I resolved this issue by uninstalling Sourcetree v3.2.6 downloading and installing the latest Sourcetree (which was v3.1.3) and I was able to commit. I then updated to v3.2.6 and was still able to commit.

So the solution seems to be to re-install Sourcetree.

Note: When uninstalling I chose to leave all my settings.

Hope this helps anyone else who has this same problem! :)

Same problem here after updating to 3.2.6 from 3.1.3

According to Windows I was still on 3.1.6 after updating although I could read 3.2.6 in the help  > about menu of Sourcetree.

I uninstalled and reinstalled version 3.1.3. It's working now, I will wait for version 3.2.7 ;-)

0 votes
Ana Retamal Atlassian Team Aug 20, 2019

Hi,

Thanks for reaching out. We'll need more information to understand your situation, can you answer the following?:

  1. What error are you getting? Can you send a screenshot?
  2. Are you using Mac or Windows
  3. Which Sourcetree version are you using?
  4. Do you get any error when you perform any other operations

Let us know!

Ana

I get the same error (just got a new laptop with Win10).

The scenario is that I stage a file and enter a commit message. When I click the "Commit" button, Sourcetree unceremoniously crashes and I get the BugSplat popup:

bugsplat.PNG

I have sent several error reports.

OS: Win10
Sourctree: 3.2.6
Other errors: none found yet

Like kimjoohwan likes this

Same error on my side. Windows 10..

Like alpereira7 likes this

Me too. Every single time. I cannot commit a thing.

Like alpereira7 likes this
Like alpereira7 likes this

I found a way to solve this. (At least for me it worked.)

Download the 3.1.3 (Windows) version from here and after installing and running it will notify you about an update. Simply update if from the old version to the new one and it seems to have corrected the problem.

No crash since with 3.2.6.

Like # people like this

I have tried this solution and unfortunately it didn't seem to work for me. :(

Has anyone else found a new solution?

Same here, v3.2.6 on Windows 10. I don't believe it started happening immediately after I updated, rather I had done a couple things (including starting and deleting a git flow feature branch, etc.) before it started.  Pretty sure I had first committed successfully at some point after updating (but couldn't swear to it).

Unfortunately I can't reinstall very easily (company machine without admin access).. just working around w the cmd line for now.

I am a brand new user to source tree.. I downloaded the code set it up and then it offered to upgrade to 3.2.6..  Which I did.. And following your tutorials, I tried my first commit.. Crash..  Uninstalled and reinstalled 3.1.3, works perfectly fine..

I submitted two splat bug reports..

Not looking good to me as I'm attempting to evaluate the software..

me too. I'm the first time user of SourceTree.

just installed today, setup, commit and bug splat.

On Windows 10, uninstalling - then reinstalling 3.1.3 - followed by updating to 3.2.6 solved the problem for me.

Same problem. Sent 2 crash reports in, will try the suggested steps from community members above.

 

It's my first time installing it on this machine, maybe something in the previous version that's required isn't being installed correctly in the latest installer? Just a guess considering the issue resolution steps above seem to indicate downgrading and then upgrading fixes the issue.

Version SourceTreeSetup-3.2.6 is having an error, so install older versions ( SourceTreeSetup-2.6.10)

I also had the same issue as above - New installation ( windows 10 latest update) of 3.2.6 the version recommended on the website - worked for about an hour and then crashed every time I tried to commit. 

 My solution was the same as everyone else - go back to 3.1.3 ( upgrade has the same issue) - I've submitted several bug splat reports but as this is now 20+ days since it was first reported - I assume that there won't be a fix in this version and we just don't upgrade till the next version?

I can confirm that we had this problem on 3.2.6.  We happened to have a 3.1.3 installer luckily, so we were able to downgrade, which fixed the problem.

Same issue for me, new laptop installed v3.26 and cannot commit - crashes

Going to try downloading older version 3.1.3 as suggested and then updating, thanks

Same problem, but when I installed 3.1.3 pressing Commit or Push did nothing, after updating to the 3.2.6 version it got back to crashing again

  • Add to Phrasebook
    • No word lists for English -> English...
    • Create a new word list...
  • Copy

Same issue for me too.

Win 10 Pro 17763.805

ST v 3.2.6.3544

Tested with: System Git v 2.23.0 with LibGit2Sharp 0.25.4

Tested with System Git v 2.23.0 without LibGit2Sharp integration

Tested wiht Embeded Git v 2.21.0 + LFS v 2.7.1 with LibGit2Sharp 0.25.4  

Tested with Embedded Git v 2.21.0 + LFS v 2.7.1 without LibGit2 integration

How to reproduce this:

1. Open ST.

2. Create a new Git repo in c:\repos\test

3. Create a new file: testing.txt

4. Stage testing.txt

5. Add "first commit" in comment textbox

6. Push Commit button

7. BugSplat shows.

I had the same issue on a Windows 10 device using ST version 3.2.6 but resolved it by

  1. Installing v3.1.3 from archives page.
  2. Making a commit on v3.1.3 and establishing my username and email on the dialogue box after clicking the commit button.
    (Not sure if this is relevant, but like a lot of the posters above, I'm a new user and v3.2.6 closed with BugSplat without showing a "user setup" dialogue box so the issue may be happening there).
  3. I updated back to v3.2.6 again and was able to commit perfectly.

ST-snip1.png

 

ST-snip2.png

I wasn't able to get a screenshot of the dialog box, but hoping this may add provide more info.

I had the same problem. Seeing post I tried adding my global information using the sourcetree terminal:

git config --global user.name "My Name"
git config --global user.email "my@email.com"

 Now it no longer crashes

Like # people like this

I had the same issue on a Windows 10 device using ST version 3.2.6.
Then have installed 3.1.3 and it worked!
I will remain with the old version for a while!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,995 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you