It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Connecting to github from Sourcetree hangs after credentials entered

I am trying to connect Sourcetree to my github repo.  I am using version 2.7 on the mac.

I am using 2FA.  Once I enter all my credentials successfully, the window says

 

You are being redirected to the authorized application

If your browser does not redirect you back, please click here to continue.

 

However, the browser never redirects (I've waited quite some time), nor does "click here" do anything.  My only option is to cancel, and the account is not added.

Any ideas?

Thanks,

 

Josh

3 answers

0 votes
bgannin Atlassian Team Mar 19, 2019

Hi @Joshua Dubey,

Is there any interesting networking in the way (managed by IT, firewall[s], etc.) out of curiosity? Are there any interesting logs in the Console app related to Sourcetree/GitHub when you do so? Sorry for the hiccup.

Brian Ganninger
Principal Developer, Sourcetree

Hi Brian,

No firewalls, etc. that I know of.  I have no trouble connecting to Bitbucket repos, even with 2FA.

I upgraded to ST 3.1 for the mac, and the issue above went away, but I am having different issues now where either ST complains about not being able to upload a public key, even after I've added it manually to github; or if I use HTTPS, ST claims my login credentials are wrong.

I tried connecting to github with their desktop client and I was having almost identical issues, so it might not be ST related.  Some research I've done leads me to believe it might have to do with it being a private repo (though that seems odd).

When I have some more time I can give you more details on all the scenarios, if you think it will help.

Also, git works fine from the command line.

Thank you for your response,

Josh

same problem for me. thanks.

Mac OS X version 10.11.4

Sourcetree Version 2.5.3

I am facing the same issue.

Same problem here.  Sourcetree 4.0.1

Found a fix. Restarted my mac and it works ok. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,917 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you