It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't install SourceTree for Windows Edited

Joyful Software Sep 04, 2017

Up to yeterday everything was fine. Yesterday SourceTree became unable to locate git on my Windows 10. I tried to update it - without success. I uninstalled it, and now can't install it back with the following error: http://prntscr.com/gh82f7. I do remember my password, I can log in to atlassian.com.

Any ideas how to install SoureTree back?

PS: I tried to install 2.1.11, 2.1.10 and 2.0.20.

1 answer

1 vote
Ana Retamal Ortiz Atlassian Team Sep 05, 2017

Hi Joyful, please follow the steps for a clean uninstall below: 

  1. Wipe SourceTree preferences
  2. Uninstall SourceTree (if it shows on the App&Features list)
  3. Backup then delete the directory below before proceeding with next step
    • Navigate to C:\Users\<UserName>\AppData\Local and delete SourceTree & SourceTree-Settings folder
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all SourceTree Files/Folder.

After that, you can download SourceTree and install it. 

Once SourceTree is installed, open Internet Explorer, go to the Advanced options tab, click on Reset your Internet Explorer Settings and check Delete personal settings This seemed to work for other users that were experiencing the same problem when loging to their Atlassian account.

Let us know if this worked for you!

Cheers,

Ana

Joyful Software Sep 05, 2017

Hi Ana,

Thank you for the answer, but it doesn't help.

Here is the line from sourcetree.log:

ERROR [2017-09-05 13:08:44,946] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied

Denis

Art Box Sep 05, 2017

Same as my problem - same repeated error in log entries.

I just ran trough the cleanout suggested and retried  - no difference.

Installer still fails to get past login showing red bar with following text: "We've encountered a problem. Please try again in a few minutes."

Seems there is an error with the Atlassian server? It did get past login once (during lots of install/login attempts) but showed 404 error when trying to download required resources:

"Download of Git Credential Manager for Windows - Fork from https://downloads.atlassian.com/software/sourcetree/windows/gcmw-v1.12.0.zip failed because: System.Net.WebException: The remote server returned an error: (404) Not Found"

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

467 views 0 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you