Branches with no root

Good day. Recently I have met this strange behavior in SourceTree. I get branches with no root. Although I branch them from existing branches or fetch them from repos, where I know they are branched from existing branches. I do not know if it is just a visualisation error or something is wrong with the repo itself. Please help figure this out!
branch-with-no-root.jpg

I am on windows. SourceTree version 1.9.6.1.

1 answer

It's just barely cut off on your screenshot, but make sure you are in 'Ancestor Order' not 'Date Order'.  I've seen this kind of display when accidentally viewing in 'Date Order'.

 

Screen Shot 2016-08-15 at 9.07.07 AM.png

Yes, just figured that out myself. Thank you for confirmation. Seems like SourceTree suddenly started using Date order by default (or maybe I changed some configuration with an accidental keypress).

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

828 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you