Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,722
Community Members
 
Community Events
168
Community Groups

After upgrading SourceTree, the Push dialog no longer shows branch mappings

After upgrading SourceTree by uninstalling the old version, installing the latest downloadable version, then accepting the auto-upgrade to v3.2.6, the push dialog box no longer shows remote branches for any repository. I've tried closing a repository and reopening it in SourceTree (by closing the tab, reopening the folder), which did not help. The git config still contains the correct configurations, as I can push from bash or from Visual Studio Code. How can SourceTree be made to display the branches in the push dialog box?

SourceTree v 3.2.6

sourcetree-no-remote-branches.jpg

4 answers

In my case it was caused by an older version of git (prior to 2.13.0) not understanding the --format option to git branch command. Upgrading to Git 2.23.0 solved the problem.

Thank you for posting this.  Upgrading from my pre-2.13.0 version of Git solved this problem for me.

Thank you! Upgrading Git solved the problem for me.

I'm also experiencing the same problem. Using the command line for pushing for now.

Not for me. I'm on git version 2.22.0.windows.1

I can only suggest to follow Mike's instructions in https://community.atlassian.com/t5/Sourcetree-questions/After-upgrading-to-Sourcetree-3-2-6-the-push-dialog-doesn-t-show/qaq-p/1172305 on how to find out what the output is of the git command used in the GetBranchesForPush entry in the Process Viewer of SourceTree. Hopefully that will give you a clue what is going wrong for you.

I'm experiencing this same issue.  For now I'm pushing from the cmd line.  The push is properly reflected in the GUI when the repo is refreshed.

Same problem here.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events