Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,205
Community Members
 
Community Events
176
Community Groups

Want to convert SVN repository into GIt

Hi ,

I have SVN repository (Data Size ~1.4 TB). I want to migarte it to Git .But due to heavy data size Git Clone method which i was referring  'https://www.atlassian.com/git/tutorials/migrating-overview 'is not useful in this case due to big data size.

So to tackle this i tried svn local data export and then below git commands in order to convert it to Git 

mkdir repo && cd repo
git svn init http://subversion/repo --no-metadata
git config svn.authorsfile ~/authors.txt
git svn fetch

but somehow not able to above init command and getting below error.

"svn: E235000: In file '/build/subversion-owKwd0/subversion-1.13.0/subversion/libsvn_subr/dirent_uri.c' line 1684: assertion failed (!"URI canonicalization failed")
error: git-svn died of signal 6"

after online search for above error tried brew package installation (my system is Ubuntu 20.04.4 LTS (GNU/Linux 5.13.0-1031-azure x86_64
) ,but this solution also not resolve my issue .hence again reverted brew installation.

After this though there is all required tools installed' java -jar  svn-migration-script.jar  verify' command gives below error ,

errors:
Can't load '/usr/local/lib/x86_64-linux-gnu/perl/5.30.0/auto/SVN/_Core/_Core.so' for module SVN::_Core: libsvn_diff-1.so.0: cannot open shared object file: No such file or directory at /usr/lib/x86_64-linux-gnu/perl/5.30/DynaLoader.pm line 193.
at /usr/local/lib/x86_64-linux-gnu/perl/5.30.0/SVN/Base.pm line 59.
BEGIN failed--compilation aborted at /usr/local/lib/x86_64-linux-gnu/perl/5.30.0/SVN/Core.pm line 5.
Compilation failed in require at /usr/share/perl5/Git/SVN/Utils.pm line 6.
BEGIN failed--compilation aborted at /usr/share/perl5/Git/SVN/Utils.pm line 6.
Compilation failed in require at /usr/share/perl5/Git/SVN.pm line 32.
BEGIN failed--compilation aborted at /usr/share/perl5/Git/SVN.pm line 32.
Compilation failed in require at /usr/lib/git-core/git-svn line 23.
BEGIN failed--compilation aborted at /usr/lib/git-core/git-svn line 23.
git-svn: ERROR: Unable to determine version.

Could you please help me how i can resolve this issue and then further start git conversion from my svn Export data .Please note exported SVN data having all revisions history information .

 

0 comments

Comment

Log in or Sign up to comment
TAGS

Atlassian Community Events