It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree not showing watched remote repos

I'm setting up Bitbucket for our team for the first time.  I've created some repos and assigned team members.

When I go into SourceTree everything is great.  All the team repos are listed automatically in the remote repository list under New Tab > Remote.

However, when teammates do the same, no repos are listed.  I found old posts about needing to watch/follow other users repos to get them to show in the list (which makes sense).  So I had a teammate watch one of the repos in Bitbucket, but it still won't show in his remote list in SourceTree.

However, that teammate can manually enter the info and clone successfully in SourceTree, so it's not a rights issue.  They have rights and are watching it, so I'm not sure why it won't show in the remote list.

As another test, I had the teammate create a private repo and give me admin rights to it.  I can access the repo in Bitbucket and I started watching it, but it won't show in my remote list in SourceTree.  And of course, I can manually enter the info and clone successfully.

Am I missing something?  Anyone else have this problem?

 

Bitbucket Cloud

SourceTree 2.1.2.5, HTTPS

Windows 10

10 comments

Same problem here, reinstalled my computer from scratch yesterday, and I can't see any repo in the remote tab. I was able to see them prior to reinstall.

I was able to clone one repo by using the URL given in the web interface.

I'm using Bitbucket Server and I can't find a way to "watch" a repo like you would do on Bitbucket Cloud, is there anything like that?

My teamate's just updated his SourceTree app and is still able to see all repo listed.

Bitbucket Server (v5.2.2)

SourceTree 2.6 (123) via HTTPS on macOS Sierra (10.12.6)

I have the same problem with Github.

I can see watched repos on Remote repositories tab with Windows client (Windows 7, Sourcetree 2.1.10.0, git embedded git 2.13.2)

but I can't see them on Mac client. (macOS Sierra 10.12.6, Sourcetree 2.6.1(126), git embedded git 2.10.1)

Did anyone find a fix? Thx

not yet...

To workaround, you can login to your bitbucket web interface, open the project, click on "Clone" and then click on the "Clone in SourceTree".

But that's a lot of operations to mimic what was the remote tab...

SourceTree 2.7 fixed it!

Like Nickson Langsdorff likes this

SourceTree 2.7.6 broke it?

I don't think so, it's still working properly on my laptop with 2.7.6 (MacOS 10.13.6).

Are you on windows?

No, it was a fresh install...

Jumping onto the bitbucket website, navigating to the repo, choosing "Clone" and then "Clone in SourceTree" worked... but it is still a bit odd it didn't show up...

My bitbucket server is listed in sourcetree with HTTPS protocol, basic auth. If I remember correctly, configuring it with SSH had some issue back then (as I have my own instance of bitbucket in my LAN, I don't rent it, so maybe it's different for you).

Ahh yep, we were using SSH as well

I have the same problem. Did anyone find a fix? Thanks.
SourceTree 3.1.2 (216) on macOS Mojave (10.14.4)

3.2.1 on macOS Catalina still has this issue.

After upgrading to 3.2.6, I am facing this problem. The repos list does not include repos from certain projects. However, those projects were listed in the earlier version. It looks like a code with a previous bug was checked in before 3.26 release. Please do something about it. Thanks. 

Version 3.2.6, Still have this bug.

Like reignydeyz likes this

Cannot push to the remote repos.

The box that shows the remote sites is empty...

image.png

Hi guys. It appears that the old Git which is probably installed on your machine is messing with SourceTree. Please update your Git then re-open SourceTree. I got mine working again. :)

Comment

Log in or Sign up to comment
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

1,644 views 0 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you