page properties report macro - no content displayed

Hello,

I have a problem with the page properties report macro. I want to output a table which lists all pages with a specific keyword - so I use this macro.

I just set the label templatetst in the macro. Some pages (in the same space) get the label.

But the macro-table is always empty. I don't know how to output the labeled-pages in this macro.

Can anybody help me?

Is it also possible to output the creation-date and the last-modification-date in the table?

Thanks for some help!

Best regards,

Timo

7 answers

This widget could not be displayed.
David Maye Atlassian Team Nov 24, 2013

It sounds that you're placing the Page Property Report Macro on each of your pages instead of the Page Property Macro. These are two separate macro's that tie into each other.

To add the labels to each of the pages, you use the Page Property Macro. For the macro that details all of the pages that have the labels set by the Page Property Macro, you use the the Page Property Report Macro. This may be why you're not seeing any information.

Page Property Report Macro:
https://confluence.atlassian.com/display/AOD/Page+Properties+Report+Macro

Page Property Macro:
https://confluence.atlassian.com/display/AOD/Page+Properties+Macro

This widget could not be displayed.

hi,

i have actual data in the page  property in few pages but in the report macro i see only 1 row.

another strange thing that is hapening, after first setup of the report macro, when i delete the labe on the displayed page i still see only this page in the report macro.

 

any idea someone?

I have the same problem.

i have a page with 4 sub pages, and only 2 are displaying on the report. The missing two were copies of one of that pages that is showing - so the page properties macros and the lable cannot be different!

We restarted our confluence, the DB it uses, and re-indexed it, and this is working again now :)  Missing pages just appeared.

This widget could not be displayed.

Having the same problem. Could it be that this macro has conflicts with plugins such as subspace? I tried everyting: labels, lables with or without numbers and "-", setting page properites ID, specifying space, using current space, but NOTHING! Is this macro an unfunny joke?

This widget could not be displayed.

Same problem here... Als tried the advice of David, but still no data.

This widget could not be displayed.

Have the same problem, although I do have the Page Property Report Macro and the Page Property Macro added both. The labels do match too, but the report macro still does not show the content. Any ideas?

This widget could not be displayed.

This might be a little bit late, but could help others in the future.

This drove me crazy for an hour or so. You need to have some actual content in the Page Property Macro not just the Page properties ID. If you don't wish to display it on the view you can use the 'Hidden' checkbox. 

This problem drove me crazy as well.

 

@atlassian team: please update the documentation, it feels kinda like a ugly work around we need to do to make it work. It is not working intuitive right now.

This widget could not be displayed.

I have the same problem that Hajo has.  I'm trying to follow David Keenan's advice but everything I do doesn't work, I still end up with an empty report. I have tried a bunch of ways to "add actual content in the Page Property Macro" but still I am failing.

Help would be greatly appreciated.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Statuspage

What are your best incident management tips and stories? #HugOps

 👋Community members! Downtime happens. And great incident response takes a village. Teams like Support, Dev, SRE, Ops, IT, and Marketing have to come together to resolve the problem while keep...

70 views 2 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you