Using Suite Utilities for Jira to update a custom field or Label via Transitions

Hi,

I am trying to accomplish this solution:

1) Use Workflow Transition as we move from one set of Workflow Statuses to another

2) We call these stages. So some Workflow Statuses are in DEV(elopment), some are in INT(egration) and some are in REL(ease)

3) I was trying to create a Custom Field that held DEV, INT and REL of which I did

4) as we transition from one Statuses , this custom field would be updated to match which status group you were in.

5) I created the transistion and used the Suite Utilities advanced option that works with custom fields, but was not showing and transistions. I set the custom field to display on the issue ticket which if I manually set it will at least diaplay what I selected.

6) I would prefer a Label that display one of these three so a user could not modify manually, is that possible?

 

I am using the latest JIRA and Suite Utilities updates.

3 answers

You can check out Label Manager plugin to restrict modifiying label items by users. To change the value of your label custom field you can use workflow essentials plugin.

Hi,   I am still not able to get an update in a custom field. I am currently working with the Workflow Essentials plugin.  Here is exactly what I am doing:

  1. I create a custom field called "Stage"
  2. I assign it a default value of "None"
  3. I assign it to the project screen I will use it under
  4. I add a Transition to the work flow from a "To Do" Status to "In Progress Status"
  5. In the Post Function, I choose the "Update/Set custom field to pre-definied value Function"
  6. I choose the "Stage" field for the Set Field
  7. In the New Field Value, I enter "DEV"   (not sure if this is what they mean by value since nothing exists in JIRA to get an actual numerical value)
  8. Save and then move it to the bottom of the order of default post functions
  9. I publish it and reindex.
  10. I got to an existing Issue in that project and change the workflow to go from TO DO to In Progress and nothing appears. If I do an admin to add the field, it appears, but nothing changes if I run through the workflow again.

Am I missing something ?

When it asks for a value to change to in the post function, does it accept text or is it expecting an actual numerical value of "DEV"?  If so, what am I supposed to be generating to get a value?

Or should I use a Multi-Line Text Field, give it the 3 entries I need  (DEV, INT, REL) and then get the numerical value of each, put in the actual value of DEV?

Christopher, any updates on my last issue or questions ?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

132 views 6 8
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you