JUnit Parser UTF-8 Problem in Bamboo with chine special-characters

In the Error Log in bamboo the message in looking like that:
expecting [????], actual was [??????‚]

This is what i wanna see:
expecting [中国河北省邢台市南宫市], actual was [中国河北省邢台市]

The Jnuit results.xml is valid and in UTF-8!

In bamboo i also tryed to change the wrapper.conf file with "wrapper.java.additional.X=-Dfile.encoding=utf-8" without a good result..

Is this a JUnit Parser Problem i think..

3 answers

This widget could not be displayed.

Hi Mad,

Can you check from the system informatio in Bamboo to ensure that the file encoding has taken effect? Also check that your database is using the utf8 encoding sheme

Regards,

Sultan

This widget could not be displayed.

thx for the feedback.. and ja file encoding is in effect.. the parcing is the prob..

This widget could not be displayed.

I have the same kind of issue with out Bamboo installation, any other clue on this issue ?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

66 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you