It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JUNIT xml encoding

Hello,

I generate UTF-8 xml file with no ASCII character, like Chinese, Japanese or Russian letter, they are converted as '?' in the html page of the bamboo test result page.

If I load my file in Webkit t is displayed correctly regarding the declared encoding.

Something is wrong with the JUNIT parser

Thanx in advance

Gerard

1 answer

There is a big confusion in the handling of junit xml file

When I log them during the script that get them built, I get corrrect encoding in the 'LOG' tab as summary, but when I ask to 'View' the complete log, the display is messy with ASCII value of the UTF8 encoded caracters

And in the 'Test' Tab I get '?' for no ASCII caratcters...

Something is truely wrong in this stuff

Bamboo version 5.2 build 4003

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Next-gen

Keyboard shortcuts have arrived for next-gen projects!

...ollected feedback from users around the lack of shortcuts, and we’re here to address that: In next-gen projects, I miss the keyboard shortcuts badly. This is particularly true on the Board, but also i...

279 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you