Instance from EC2 micro running, Elastic agent pending

I created an ami image in ec2 and configured bamboo to use that for the starting the build machines. However that's not happening. On clicking start new elastic agent bamboo build machine instance gets created and gets to state running spawning the elastic agent. However the elastic agent stays in the pending state for about 44 mins and then the instance gets terminated. I need help to fix this problem.

1 answer

This widget could not be displayed.

Hi Sushil,

on the Elastic Instance, what is in your /home/bamboo/bamboo-elastic-agent.out file?

If this file is missing, your agent isn't starting at Systemboot. Then you need to add this statement /opt/bamboo-elastic-agent/etc/rc.local to your /etc/rc.local file, or provide it with your startscripts (e.g. upstart or /etc/init.d)

If your Elastic Agent still wont start, have a look at /home/bamboo/bamboo-elastic-agent.out what error-message you got

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

28 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you