Confluence Install stuck

I'm installing JIRA and Confluence on a Windows 2008 server R2. I have followed the Here Be Dragons Guide( and my confluence install is stuck on step 4 (http://ridge-serv:8090/setup/connecttojirasyncdirectory-start.action). I have tried to setup JIRA and Confluence to have the same users. When this page loads, I get the following output -

Load users and groups from JIRA

Full synchronisation completed successfully.

Time Elapsed:Less than a second

Local administrator account created.

We have created a local administrator with the same username and password as the JIRA system administrator you provided. This will ensure that you can always log into Confluence to update the system configuration.

The NEXT button does not allow me to click on it and proceed to the next step.

Any thoughts???

16 answers

1 accepted

Thanks for your help, HTML Change worked for me.

edited ~/atlassian/confluence/confluence/setup/connecttojirasyncdirectory.vm

changed line 18 from disabled="disabled" to activated="activated"

That did the trick! Thank you.

very very thank you!! really

Thank you very much!!. ^.^

Same problem here :/


//EDIT: The solution was simply manipulate the HTML Button to "aktivated".

Haha, nicely done mate! activated="activated" worked for me too. Thanks!

I had the same issue, installing Confluence with JIRA for the user database on CentOS. This "hack" worked for me as well; sounds like some testing path was missed, Atlassian...


Just let us know exactly which button is not working, if is the case you can create a support ticket to have a better investigation.

As I indicated in my original statement, the NEXT button does not allow me to click on it and proceed to the next step.

As I indicated in my original statement, the NEXT button does not allow me to click on it and proceed to the next step.

Did you solve this problem? I'm having the same issue.

I am having the same issue. I am currently unable to proceed to the next page.

It's very likely this problem is occuring regarding this bug:

We recommend you to try installing Confluence with just Internal Users for now. After the installation completes, the go to Confluence Admin > User Directory and create your Jira Directory.


I don't get the option to install it with internal users even when I am using the "Custom" install. Was anybody able to solve this problem?

I hope somebody in Atlassian support responds too this soon

I had exactly the same problem. Changed activated="activated" funny ...

And I need to submit this work soon. Any help please!!!

I had the same issue while installing latest version to date of the Confluence on CentOS. After modification of the vm file as mention above it worked:


changed line 18 from disabled="disabled" to activated="activated"

Thanks for the hint! activated="activated" also worked for me!

Installed latest version standalone today. Same issue. Used this workaround and got it running. But when this issue will be fixed, i wonder?

I had the exact same issue and here are the steps that I followed to get to this point:

sudo wget
sudo chmod a+x atlassian-confluence-5.4.1-x64.bin
sudo ./atlassian-confluence-5.4.1-x64.bin

- choose Custom Install (option 2)

confluence install location, use default.
confluence data location, use default.
confluence HTTP port, use default.
confluence control port, use default.

then choose YES, to install Confluence as a service.

go to http://localhost:8090/
Note: I have apache2 in-front of confluence (on port 80) and access it as

On the "Confluence Setup Wizard" page:
- enter your license information.
-- I used a trial license.
- select "Production Installation" button.

On the "Choose a Database Configuration" page:
- choose "PostgreSQL" as an external database.
- select "External Database".

On the "Configure Database" page:
- choose "Direct JDBC".

On the second "Configure Database" page:
- [Driver Class Name], use the prefill
- [Database URL] changed it to "jdbc:postgresql://"
- [User Name], I used confluence
- [Password], what ever the postges confluence password is.

press the "Next" button and wait while confluence sets up the database.

On the "Load Content" page:
- select the "Empty Site" button.

On the "Configure User Management" page:
- select the "Connect to JIRA"

On the "Connect to JIRA" page:
- [JIRA Base URL]
- [Username]
-- [use the JIRA administrator account from the "Set Up Administrator Account" JIRA step]
- [Password]
-- [use the JIRA administrator password from the "Set Up Administrator Account" JIRA step]
- [Confluence Base URL], use the prefilled
- [User Groups] use the prefilled jira-users
- [Admin Groups] use the prefilled jira-administrators

press the "Next" button and wait while confluence sets up the JIRA connection.

On the "Load users and groups from JIRA"
- wait for the "Next >>" button to become enabled... NEVER!!!

- There is a bug in v5.4.1 of confluence such that the "Next >>" button is still disabled after the administrator account has been created.
- To fix this, edit the file connecttojirasyncdirectory.vm:
-- sudo vim /opt/atlassian/confluence/confluence/setup/connecttojirasyncdirectory.vm
- change line 18 from disabled="disabled" to activated="activated".
- refresh the "Load users and groups from JIRA" in your browser.

- press the "Next >>" button.

Note: I am running everything on the same server, I just changed the first line of the hosts file to: localhost

Note: This was a clean install on a clean ubuntu 12.04 LTS server.

Just discovered another issue with this version of confluence ...

... this install package will reset the <Context path="X" ...> to <Context path="" ...>

That is to say if you have previously configured jira to use the upgrade will reset it to destroying any access to the instance if it is actually behind apache.

This is also true for the latest installation package for confluence :(

P.S. This issue (and others with this version) has now already wasted two mandays for me and has seriously shaken my believe in this product. I hope you guys clean this up on the 14th.

Just ran into this issue as well. Fresh install of Confluence, selected postgresql DB, and opted to use JIRA for user management. A quick workaround is to just use your browser's developer console, select the "next button" element, and change the following directly in your browser: disabled="disabled" to activated="activated"

After that, you can hit Next without any issues and setup completes.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

158 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot