Confluence Install stuck

I'm installing JIRA and Confluence on a Windows 2008 server R2. I have followed the Here Be Dragons Guide(https://confluence.atlassian.com/display/ATLAS/Here+Be+Dragons) and my confluence install is stuck on step 4 (http://ridge-serv:8090/setup/connecttojirasyncdirectory-start.action). I have tried to setup JIRA and Confluence to have the same users. When this page loads, I get the following output -

Load users and groups from JIRA

Full synchronisation completed successfully.

Time Elapsed:Less than a second

Local administrator account created.

We have created a local administrator with the same username and password as the JIRA system administrator you provided. This will ensure that you can always log into Confluence to update the system configuration.

The NEXT button does not allow me to click on it and proceed to the next step.

Any thoughts???

16 answers

1 accepted

This widget could not be displayed.

Thanks for your help, HTML Change worked for me.

edited ~/atlassian/confluence/confluence/setup/connecttojirasyncdirectory.vm

changed line 18 from disabled="disabled" to activated="activated"

That did the trick! Thank you.

very very thank you!! really

Thank you very much!!. ^.^

This widget could not be displayed.

Same problem here :/

bug

//EDIT: The solution was simply manipulate the HTML Button to "aktivated".

Haha, nicely done mate! activated="activated" worked for me too. Thanks!

I had the same issue, installing Confluence with JIRA for the user database on CentOS. This "hack" worked for me as well; sounds like some testing path was missed, Atlassian...

This widget could not be displayed.

Hello,

Just let us know exactly which button is not working, if is the case you can create a support ticket to have a better investigation.

As I indicated in my original statement, the NEXT button does not allow me to click on it and proceed to the next step.

This widget could not be displayed.

As I indicated in my original statement, the NEXT button does not allow me to click on it and proceed to the next step.

This widget could not be displayed.

Did you solve this problem? I'm having the same issue.

This widget could not be displayed.

I am having the same issue. I am currently unable to proceed to the next page.

This widget could not be displayed.

It's very likely this problem is occuring regarding this bug: https://jira.atlassian.com/browse/CONF-27338

We recommend you to try installing Confluence with just Internal Users for now. After the installation completes, the go to Confluence Admin > User Directory and create your Jira Directory.

Cheers!

This widget could not be displayed.

I don't get the option to install it with internal users even when I am using the "Custom" install. Was anybody able to solve this problem?

This widget could not be displayed.

I hope somebody in Atlassian support responds too this soon

This widget could not be displayed.

I had exactly the same problem. Changed activated="activated" funny ...

This widget could not be displayed.

And I need to submit this work soon. Any help please!!!

I had the same issue while installing latest version to date of the Confluence on CentOS. After modification of the vm file as mention above it worked:

~/atlassian/confluence/confluence/setup/connecttojirasyncdirectory.vm

changed line 18 from disabled="disabled" to activated="activated"

This widget could not be displayed.

Thanks for the hint! activated="activated" also worked for me!

This widget could not be displayed.

Installed latest version standalone today. Same issue. Used this workaround and got it running. But when this issue will be fixed, i wonder?

This widget could not be displayed.

I had the exact same issue and here are the steps that I followed to get to this point:

sudo wget http://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-5.4.1-x64.bin
sudo chmod a+x atlassian-confluence-5.4.1-x64.bin
sudo ./atlassian-confluence-5.4.1-x64.bin

- choose Custom Install (option 2)

confluence install location, use default.
confluence data location, use default.
confluence HTTP port, use default.
confluence control port, use default.

then choose YES, to install Confluence as a service.

go to http://localhost:8090/
Note: I have apache2 in-front of confluence (on port 80) and access it as http://confluence.myserver.com/

On the "Confluence Setup Wizard" page:
- enter your license information.
-- I used a trial license.
- select "Production Installation" button.

On the "Choose a Database Configuration" page:
- choose "PostgreSQL" as an external database.
- select "External Database".

On the "Configure Database" page:
- choose "Direct JDBC".

On the second "Configure Database" page:
- [Driver Class Name], use the prefill
- [Database URL] changed it to "jdbc:postgresql://database.myserver.com:5432/confluencedb"
- [User Name], I used confluence
- [Password], what ever the postges confluence password is.

press the "Next" button and wait while confluence sets up the database.

On the "Load Content" page:
- select the "Empty Site" button.

On the "Configure User Management" page:
- select the "Connect to JIRA"

On the "Connect to JIRA" page:
- [JIRA Base URL]
-- http://jira.myserver.com
- [Username]
-- [use the JIRA administrator account from the "Set Up Administrator Account" JIRA step]
- [Password]
-- [use the JIRA administrator password from the "Set Up Administrator Account" JIRA step]
- [Confluence Base URL], use the prefilled http://confluence.myserver.com
- [User Groups] use the prefilled jira-users
- [Admin Groups] use the prefilled jira-administrators

press the "Next" button and wait while confluence sets up the JIRA connection.

On the "Load users and groups from JIRA"
- wait for the "Next >>" button to become enabled... NEVER!!!

- There is a bug in v5.4.1 of confluence such that the "Next >>" button is still disabled after the administrator account has been created.
- To fix this, edit the file connecttojirasyncdirectory.vm:
-- sudo vim /opt/atlassian/confluence/confluence/setup/connecttojirasyncdirectory.vm
- change line 18 from disabled="disabled" to activated="activated".
- refresh the "Load users and groups from JIRA" in your browser.

- press the "Next >>" button.

Note: I am running everything on the same server, I just changed the first line of the hosts file to:

127.0.0.1 localhost jira.myserver.comconfluence.myserver.comdatabase.myserver.com

Note: This was a clean install on a clean ubuntu 12.04 LTS server.

This widget could not be displayed.

Just discovered another issue with this version of confluence ...

... this install package will reset the <Context path="X" ...> to <Context path="" ...>

That is to say if you have previously configured jira to use http://server.com/jirathen the upgrade will reset it to http://server.com... destroying any access to the instance if it is actually behind apache.

This is also true for the latest installation package for confluence :(

P.S. This issue (and others with this version) has now already wasted two mandays for me and has seriously shaken my believe in this product. I hope you guys clean this up on the 14th.

This widget could not be displayed.

Just ran into this issue as well. Fresh install of Confluence, selected postgresql DB, and opted to use JIRA for user management. A quick workaround is to just use your browser's developer console, select the "next button" element, and change the following directly in your browser: disabled="disabled" to activated="activated"

After that, you can hit Next without any issues and setup completes.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 22m ago in United States

Local Atlassian Research Workshop opportunity on Sep. 28th

We're looking for participants for another workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sh...

8 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you