Calling PowerShell from SourceTree custom action

Is it possible to call a PowerShell script from a custom action in SourceTree?

I've tried adding it directly as the "Script to run", as well as using "powershell" as the script to run and then adding the actual script as one of the parameters.

Same result in both cases - the script is not called, and the SourceTree progress dialog when running the custom action never finishes. I have to press the Cancel button to stop the execution.

I've also tried wrapping the PowerShell script inside of a Batch file, but the same happens again - it never finishes. Running the batch file from command line works perfectly fine.

Is there a working example for running a PowerShell script from a SourceTree custom action?

2 answers

Can you view details when running the custom action? If so, is there anything there?

You might try experimenting with running a random powershell script that requires no parameters. It may be that the parameters you're using need escaped or quoted differently.

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

288 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot