Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Unable to set a responder in Opsgenie integration

Samuel Mosher
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 3, 2023

We are testing out Opsgenie with a CheckMK integration. In the integration documentation it states that there should be a Responder field that we can use to assign alerts to. Without assigning alerts, our team does not receive notifications.

However, in our Opsgenie instance, the Responder field does not appear on the integrations page, and appears to only be available to add manually to each individual alert. Is this an oversight on my part, a plan limitation, or something else?

1 answer

0 votes
John M
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 3, 2023

Hi @Samuel Mosher ,

If you are on the Free or Essentials plans, integrations can only be added on the team level, but not the global level. When integrations are team-based, the 'Responders' field is not present, as all alerts will be assigned to the team that the integration is assigned to.

Likewise, If you are on Standard or Enterprise plans, the "responders" field will not be present if the integration is assigned to a team, but on these plans, you can remove the team and the integration will be global, which will enable the 'Responders' field. 

Samuel Mosher
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 3, 2023

Hi John!

Thanks for getting back to me. We are on the free plan, and the integration is set up at the team level. All inbound alerts however do not assign to the team. I do see that Responder Team on the Team integrations page shows as our team next to the integration.

At the team level, we have a routing rule that is:
IF for any received alert THEN route the alert to our_team_escalations

We also have an escalation rule that is:
IF alert is not acknowledged THEN 1 min after creation, notify on call users in our_team_schedule (note the 1min is just for testing, we plan on having a longer delay once rolled out).

There is currently one person in the on-call schedule (myself) and I do not receive any notifications even though alerts show up in Opsgenie.

I have email, SMS, and voice configured. In my profile, it it set to notify me immediately for new alerts on all three channels.

Do I have something misconfigured or am I missing a step?

John M
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 3, 2023

Hi @Samuel Mosher ,

I would recommend submitting a support ticket so we can review your configuration. There are simply too many variables to say why you are not getting the notifications without looking at the account. If you are still in the trial period you should also have access to in-app chat on the Free plan. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events