Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,450
Community Members
 
Community Events
176
Community Groups

OpsGenie to ServiceNow Issue

Edited

Hi All,

 

We have integrated Opsgenie with ServiceNow. However it is currently working only unidirectional.


From ServiceNow to Opsgenie it is working fine. When we create an incident in Servicenow, the alert is generating in Opsgenie. If we add notes in Servicenow it is also reflecting in OpsGenie.
But when we add notes or acknowledge alert in Opsgenie then Servicenow is not updating with notes.
When we checked the logs it is showing below error: 

 

(len:4219) [system] Could not send [createIncident] action to ServiceNowV3 [ServiceNow] after 5 retries. Reason: 500 Internal Server Error: "<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"><EOL><html><head><EOL><meta type="copyright" content="Copyright (C) 1996-2022 The Squid Software Foundation and contributors"><EOL><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><EOL><title>ERROR: The requested URL could not be retrieved</title><EOL><style type="text/css"><!-- <EOL> /*<EOL> * Copyright (C) 1996-2022 The Squid Software Foundation and contributors<EOL> *<EOL> * Squid software is distributed under GPLv2+ license and includes<EOL> * contributions from numerous individuals and organizations.<EOL> * Please see the COPYING and CONTRIBUTORS files for details.<EOL> */<EOL><EOL>/*<EOL> Stylesheet for Squid Error pages<EOL> Adapted from design by Free CSS Templates<EOL> http://www.freecsstemplates.org<EOL> Released for free under a Creative Commons Attribution 2.5 License<EOL>*/<EOL><EOL>/* Page basics */<EOL>* {<EOL>?font-family: verdana, sans-serif;<EOL>}<EOL><EOL>html body {<EOL>?margin: 0;<EOL>?padding: 0;<EOL>?background: #efefef;<EOL>?font-size: 12px;<EOL>?color: #1e1e1e;<EOL>}<EOL><EOL>/* Page displayed title area */<EOL>#titles {<EOL>?margin-left: 15px;<EOL>?padding: 10px;<EOL>?padding-left: 100px;<EOL>?background: url('/squid-internal-static/icons/SN.png') no-repeat left;<EOL>}<EOL><EOL>/* initial title */<EOL>#titles h1 {<EOL>?color: #000000;<EOL>}<EOL>#titles h2 {<EOL>?color: #000000;<EOL>}<EOL><EOL>/* special event: FTP success page titles */<EOL>#titles ftpsuccess {<EOL>?background-color:#00ff00;<EOL>?width:100%;<EOL>}<EOL><EOL>/* Page displayed body content area */<EOL>#content {<EOL>?padding: 10px;<EOL>?background: #ffffff;<EOL>}<EOL><EOL>/* General text */<EOL>p {<EOL>}<EOL><EOL>/* error brief description */<EOL>#error p {<EOL>}<EOL><EOL>/* some data which may have caused the problem */<EOL>#data {


Also when we create a new alert in OpsGenie, the incident is not creating in Servicenow.
No Logs were present in OpsGenie.

Request you to please inform the details for email/ticket support.

1 answer

0 votes
Rafael Meira Atlassian Team Jan 10, 2023

Hey @Mritunjay Pathak 

The error message that you've provided suggests that there's an internal server error occurring when Opsgenie is trying to send data to ServiceNow.

One possible reason for this error could be a misconfiguration on the ServiceNow side of the integration. It's possible that the endpoint that Opsgenie is trying to connect to on the ServiceNow side is not set up correctly, or that there's an issue with the way the data is being sent.

Another potential issue could be related to permissions. Make sure that the user account that Opsgenie is using to connect to ServiceNow has the appropriate permissions to create incidents and add notes.

Also, you mentioned that new alert is not creating incident in servicenow and not logs are present in Opsgenie. I suggest to check the integration configuration of alert creation in Opsgenie. Confirm that the integration is set up correctly and that the correct endpoint is being used.

I recommend reviewing the documentation for both ServiceNow and Opsgenie to ensure that the integration is set up correctly and that all of the necessary configurations have been made. Also for further assistance on the Opsgenie side, could you please open a formal ticket with us? - https://support.atlassian.com/opsgenie/

https://support.atlassian.com/opsgenie/docs/integrate-opsgenie-with-servicenow/

 

Best,
Rafa

Hi Rafael,

 

Thanks for the reply.
I had referred this mentioned document while integrating Opsgenie with ServiceNow.
Also I had raised a support ticket for this OGSP-102366.

As per the above comment I will ask my ServiceNow Team to check the configuration again on their side.

Also please refer below conditions I have given during integrations.

OpsGenie Permissions.jpg

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS

Atlassian Community Events