Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,316
Community Members
 
Community Events
165
Community Groups

OpsGenie and work profiles on Android 9

How do I stop OpsGenie from popping up a message about granting it the permission to set the volume for alerts when DND is active. If you click settings, then it takes you to a screen where you can't do anything.

This is on a Pixel 3a, Android 9 with work profile enabled.

There is this discussion: https://community.opsgenie.com/t/android-9-work-profile-and-opsgenie-in-dnd-mode/1029 which shows that I am not unique. 

Thanks.

2 answers

This is not limited to the Pixel phones or OpsGenie (per documentation of other apps). Similar on 7.1.2 Sony Z5c.

The following quotation from the linked issue (which appears to be broken now) represents my experience as well:

I can’t seem to get through the Sounds/DND settings in my setup. In the OpsGenie “Sounds” menu, when I toggle the “always play opsgenie notification sounds at maximum…”, there’s a popup permission request to “Please grant OpsGenie permission to modify your Do Not Disturb settings”. When I do that, I’m taken to the “Do Not Disturb access” Android menu, where other Google services appear but not OpsGenie. I don’t see a way to get OpsGenie onto the DND access list.

 This issue prevents me from receiving opsgenie notifications even though I have the "Interrupts Priority only". I was unable to find the "Do not disturb access" screen in settings to bring up outside of the app. It appears to be only available by the "settings" link in the "permissions request" modal.

 

Screenshot_20190819-140021.pngScreenshot_20190819-140054.pngScreenshot_20190819-140048.png

 

The application shows it as a possible permission, but there appears to be no way to grant it.

Screenshot_20190819-143643.pngScreenshot_20190819-143632.pngScreenshot_20190819-143626.png

This appears to be an issue for other similar applications (from VictorOps instructions):

NOTE: If VictorOps does not appear in the list above, make sure that VictorOps was installed through phone’s main, top level account from Google Play (as opposed to a secondary or tertiary personal/work/enterprise account). If it the app has not been installed through the main account, VictorOps will not appear as an option.

@Mark Campbell-Vincentthis is a work profile install

Huy Atlassian Team Feb 17, 2021

Thanks @Adam Chasen for that post! I had the same issue under Android 11 and fixed this issue by installing OpsGenie in the main (non work profile) account, per the VictorOps note above.

@Huy is there anything on the roadmap to allow OpsGenie DND override when it's installed in a Work Profile (Samsung Android 11) since I would rather keep my personal and work accounts strictly divided

Nakul Kedia Atlassian Team Mar 17, 2021

Hey @David Hartman 
This is Nakul from the Opsgenie Android team.

The issue is due to an Android restriction.
From the Android docs:
“Managed profiles cannot grant Do Not Disturb access.”
https://developer.android.com/reference/android/provider/Settings#ACTION_NOTIFICATION_POLICY_ACCESS_SETTINGS 
 
“The Android platform allows devices to have work profiles (sometimes referred to as managed profiles).”
https://developer.android.com/work/managed-profiles   

The workaround we suggest is:
If you have Opsgenie on both “Personal Profile” and “Work Profile” you will be able to see Opsgenie in the DnD permission list of “Work Profile” and enable DnD access to Opsgenie.
If you then uninstall Opsgenie from “Personal Profile”, Opsgenie will stop showing up in the list of “Work Profile”, but it will still bypass DnD as expected.

Hope this works!
Please let us know if you have any further questions.

Like # people like this

@Nakul Kedia Have you tested this in Android 12? I can't seem to get this to work.

I added the app to both my work and personal profiles, I can see the DND permissions and set them, but when I launch the work profile OpsGenie app, it gives me the same warning ("Opsgenie requires additional permissions to override Do not Disturb...") and does not appear to be changing the alerts volumes/etc.

Huy Atlassian Team Nov 11, 2021

@Don McNamara I'm not from Opsgenie team but I am on Android 12 (Nov patch, Pixel 6) and it seems fine for me. I made sure 'Do not disturb access' (search Settings) is allowed for Opsgenie. I have it installed in both work profile and outside.

Like Don McNamara likes this

I just transitioned from a Pixel 3 (Android 12) to a new Pixel 6 Pro (Android 12) and am having the same issue. I cannot select the option to 'Allow OpsGenie to set ringtone volume'. I keep getting the Permission Request popup but the resulting screen doesn't let me do anything. I have OpsGenie installed on my personal as well as work profile.

Like Don McNamara likes this

I am also on a pixel 6 pro with Opsgenie installed on my work / personal profile.  I am able to grant the exception on my personal profile, but cannot on my work profile.  Alerts do not bypass the DND setting

Like Don McNamara likes this

Hi @wxcamera  - I'm wondering if this issue is occurring only for Pixel phones. I set up a work profile and have updated to version 9(Samsung S8), but I did not run into this issue. Just to be thorough, could you possibly disable your work profile to see if this gives the same result?

If I use opsgenie from my personal profile, then I get sent to the "Do Not Disturb access" page which does list OpsGenie, and I can then enable it. 

Now, when I start the OpsGenie in my work profile, it starts and doesn't ask me about setting the Do Not Disturb access. It would appear that this might be an Android bug as I would have thought that the work-profile opsgenie should only have access to the work profile do-not-disturb.

However, when I create a test notification (after uninstalling the personal profile opsgenie) and I have do-not-disturb enabled, the work-profile opsgenie does not succeed in disabling the do-not-disturb, so I didn't get notified.

I'm running build PQ3B. 190605.006

@Philip Gladstone Could you check if this is occurring with your other applications? Also, downloading the Opsgenie app with your work profile or your personal profile could make the difference with the DND settings. Would you know which profile was used to download the app? 

Like Monique vdB likes this

I don't recall which profile I initially download the opsgenie app -- I suspect it was my personal profile. I then downloaded it for my work profile and uninstalled the personal profile version.

I don't know how to get to the do-bot-disturb settings for work profile -- but I don't have many work apps, but I can try doing some tests with slack.

Like Monique vdB likes this

edit: promoted to top level answer

Like Mark Campbell-Vincent likes this

Hi @Adam Chasen - Is this occurring with your Work profile? Thanks for providing this information.

Also receiving this issue on my work profile.

All is fine on my personal profile

Having the same issue, really frustrating

Encountered the same issue, Pixel 6, Android 12. Had to install to my personal profile, and uninstall on work profile. Couldn't get anything else to work. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Service Management

Jira Service Management Documentation Opportunities

Hello everyone, Hope everyone is safe! A few months ago we posted an article sharing all the new articles and documentation that we, the AMER Jira Service Management team created. As mentioned ...

159 views 0 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you