Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

OpsG to JSM issue

Mick Love December 1, 2020

Hi there, I have JSM > OpsG working fine.  For some reason, If I trigger an alert on OpsG, I get an email and SMS, but it fails to create a ticket on JSM.

In the OpsG log, I can see the following Error

  • alertLogOwner System

  • responseBody {"errorMessages":[],"errors":{"summary":"Field 'summary' cannot be set. It is not on the appropriate screen, or unknown.","description":"Field 'description' cannot be set. It is not on the appropriate screen, or unknown.","labels":"Field 'labels' cannot be set. It is not on the appropriate screen, or unknown."}}

  • _outgoingData

    • _headers

      • Authorization ...

      • -Content-Type [ application/json;charset=UTF-8 ]

    • integrationType JiraServiceDesk

    • _payload

      • _fields { summary: testing 20202020, -labels: fromOG, _project: [object Object], _issuetype: [object Object], description: Click on [Body.html] attachment for HTML version Testing 123  }

    • integrationName VoIP_Jira Service Management

  • alertId d42eaa38-d2f1-45fa-ba3d-2ba5b1081d3a-1606840532978

  • alertLogType system

  • statusCode BAD_REQUEST
    I take it I am missing an setting somewhere?

Regards

Mick

2 answers

1 accepted

2 votes
Answer accepted
Nick H
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
December 1, 2020

Hi @Mick Love ,

There are a few things to review for this error.

In JSM navigate to the Settings menu >> Issues tab >> Screens tab >> click Configure for the same project’s screen that is configured in the integration’s action mapping section, and check if these fields - summary, description, and labels - are available in this screen:

JSM comm 1.jpgJSM comm 2.jpg

 

Typically when we see this error including all 3 fields missing, the fields are found in the project's Screen - and instead, it could potentially be a misconfiguration here in the integration:

JSM comm 3.jpg

 

A few things to double-check on your end:

  1. If OEC is not being used - make sure the 'Send Via OEC' checkbox is not selected. OEC is used mostly for Server instances - and typically not needed with Cloud instances: https://docs.opsgenie.com/docs/jiraservicedesk-integration#integration-via-oec-for-on-premise-jira-service-management-usage
  2. URL should only include your site name with nothing following .net
    1. Example: https://accountname.atlassian.net/
  3. Username is the email used to log in into your Atlassian site. Best practice is using a site admin's email.
  4. Password/API Token - best practice is using an API token here. This doc outlines how to generate one: https://confluence.atlassian.com/cloud/api-tokens-938839638.html
    1. After you create / copy the API token, paste it into the Password/API Token field.

Finally - save the integration, and retest.

Let us know if you continue seeing this 400 error after.

0 votes
Mick Love December 2, 2020

@Nick H thank you for the very detailed help, it ended up being my credentials. I was using my Displayed username and not my email. 

All working now :)

 

Regards

Mick

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events