Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,843
Community Members
 
Community Events
176
Community Groups

Help with debugging a team action/channel.

Hello,

      I am working on setting up a team action to send MMS notifications using Twilio.  I have configured the action channel for the Twilio REST endpoint, and have configured an action with all predefined values, following the Twilio examples.  I cannot get it to send a test message from the team action.

     In the alert log, I can see where it executed the team action, and I see in the OpsGenie logs where the action was executed, but no HTTP response information or any other helpful debugging information.  On the Twilio side, I am not seeing anything in the logs.

     I am new to creating actions, and any help in debugging a REST endpoint action/action channel would be greatly appreciated.

 

Thanks,

Michael Hilty

michael.hilty@compucom.com

1 answer

0 votes
Robert Atlassian Team Mar 10, 2020

Hi @Michael Hilty !

 

I just did a couple tests on my own account with an action tied to a request bin site (https://beeceptor.com). When I configured the request bin to reply with something like a 502 status code, Opsgenie retried the action 10 times then logged the response:

Image 2020-03-10 at 8.56.13 AM.png

So it did take a minute or so to go through the retries, but logged the status code afterward.

 

Do you at least see these entries for the action you've set up? Or are you only seeing the action was sent and/or failed?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events