Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,618
Community Members
 
Community Events
176
Community Groups

Issue with API for creating issues

Hey, 
I was hoping someone could shed some light on an issue I am having please.
I have an alert in Splunk to create a Jira issue, but it does not appear to work. The Jira replay search gives me the json content as the below, but it does not give me any errors.:
{
"fields": {
"project": {
"key": "SOCALERT"
},
"summary": "Splunk Alert - Multiple failed login attempts - The user ****.",
"description": "The alert condition for 'A028 - Multiple failed login attempts' was triggered.",
"issuetype": {
"name": "Azure Alerts"
}
}
}
So, I created a postman call to parse the above content and it does shed some light with the following response.
{
"errorMessages": [],
"errors": {
"summary": "Field 'summary' cannot be set. It is not on the appropriate screen, or unknown.",
"description": "Field 'description' cannot be set. It is not on the appropriate screen, or unknown."
}
}
I have confirmed that the create screen does indeed contain these fields, as you would expect they are the basic fields, but I still get the error. I appreciate formatting has been lost here, so attached is a screenshot.
Please, does anyone have any ideas? I am pretty certain I ran something similar a few weeks back and it worked fine.
Screenshot 2021-09-23 at 20.48.04.png

1 answer

1 accepted

0 votes
Answer accepted

Hi John,

The data format for description needs to be in the Atlassian document format if using the rest API in cloud. You can see an example on the following page:

https://blog.developer.atlassian.com/creating-a-jira-cloud-issue-in-a-single-rest-call/

Try using that format in postman. Trying the format you are using in cloud gives the following error on my test

"Operation value must be an Atlassian Document (see the Atlassian Document Format)"

Also are you trying this on a company managed project (classic) or a team managed project (Next-gen) ? and what API endpoint are you using /rest/api/2 or /rest/api/3

3 is in beta and supports the Atlassian document format. 2 would accept the format you have

Thanks, I think it is classic, I tried with the Atlassian document format and I still get the same issue on api/3.

 

{

    "fields": {

        "summary": "JL - Test",

        "issuetype": {

            "id": "10052"

        },

        "project": {

            "key": "SOCALERT"

        },

        "description": {

            "type": "doc",

            "version": 1,

            "content": [

                {

                "type": "paragraph",

                "content": [

                    {

                    "text": "This is the description.",

                    "type": "text"

                    }

                ]

                }

            ]

        }

    }

}

 

I have changed from api/3 to api/2 and changed auth from API to basic and now it is working as expected. I guess I had something wrong somewhere.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events