Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,911
Community Members
 
Community Events
165
Community Groups

Zephyr Test Case Importer Will not Import Test Cases and no Error is Displayed

Hi,

I am trying to import test cases from Excel file into Jira using Zephyr Test Case Importer (zfj-importer-utility-0.40)

I am on Server based Jira

When I fill out all mandatory information and Click Start Import, nothing happens.

No test cases are imported and no error is displayed

5 comments

Hello, i have the same problem. Everything was working fine and then one day nothing happens?! Since any one says nothing you have found the solution for yourself Natalia? Thanks

I did not find a solution :(

I made it by working around it. Start of the zephyr  from command prompt by using the following command.

java -jar <importer-utility-filename.jar>

You can also find the answer in the link below. Read @Cait M reply.

https://community.atlassian.com/t5/Marketplace-Apps-Integrations/Cannot-import-test-cases-to-Zephyr-for-Jira-using-zfj-importer/qaq-p/938227#U1200729 

Hi,

 

I have had similar issue, but when I opened the utility through command Prompt "java -jar zfj-importer-utility-0.40.jar" it worked.

 

But my question is, why doesn't it work when I open the utility normally?

I have the same issue on macos big sur, I solve it:

The problem is java version 11, it needs a lower java version

Remove the java directories into: 

/Library/Java/JavaVirtualMachines/ (maybe you've here java11)...

WARNING! if you delete this directories, apps as sql server (new versions) will be stop working.

and then setup java 8 from java.com

the importer will be working again.

Then you should upgrade again you java version to follow working with your other apps.

I have found that using OpenJDK gives an error which seems to be related to the way in which java reports its version number. The console gives this message:

Exception in thread "AWT-EventQueue-0" java.lang.NumberFormatException: Not a version: 10
at scala.util.PropertiesTrait$class.parts$1(Properties.scala:176)
at scala.util.PropertiesTrait$class.isJavaAtLeast(Properties.scala:180)
at scala.util.Properties$.isJavaAtLeast(Properties.scala:16)
at scala.actors.scheduler.ThreadPoolConfig$.useForkJoin(ThreadPoolConfig.scala:45)

Where the number after "Not a version:" represents the version of java in use (I also tried  with version 17 and got the same error but with "17" instead of "10".

 

Using Oracle JDK (and read the license before you install it) gets past this error for me.

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Apps & Integrations

Marketplace Partner Spotlight: AppLiger

This month the spotlight is on AppLiger. We caught up with Pavel Pavlovsky, CEO and Product Manager, to learn how the company started and what fuels the team's creativity.    Atlassian:...

389 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you