Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Cloud Add-In in Outlook "Something went wrong while loading add-in"

This Add-in fails to load on our citrix environment (Server 2016, Office 365, Outlook Version 2011 Build 13426.20294 )

When using the add-in I get the following error:
jira_cloud.PNG

3 answers

0 votes

Hi @Steffen Sunderdiek 

Did it work before and did it stop working recently or it never worked?

As specified on the add-in's page in Appsource, we support Outlook 2016+, which means that it won't work in Outlook 2011.

I'd recommend updating to the latest Outlook version if this is an option for you.

Hi @Vitalii Saienko ,

 

it never worked in this environment, but on my local network it works just fine.

Maybe i wasn´t clear about the version. We are using O365 which is always Outlook 2016. 
As you can see here https://docs.microsoft.com/de-de/officeupdates/current-channel the Version is from November 2020.

However, I plan on doing an update next week, but I guess this won't resolve this issue.

 

[EDIT] moved to a new answer since unrelated.

 

0 votes
Dario B Atlassian Team Mar 05, 2021

@Steffen Sunderdiek ,

From what I read this might be unrelated. However, you may also want to check if the integration actually failing because of yesterday's incident that happened between 2021-03-04 01:00 UTC and 2021-03-04 15:30 UTC:

 

Even if above link it is only mentioning the installation of new apps, we have also received some reports about already installed apps and/or already configured integrations were failing, and the returned error was indeed 500 (Internal Server Error).

 

 

Cheers,
Dario

I just finished updating the office installation in citrix and tested again.

Our Office Version now is:
Capture.PNG

 

Apparently it is still not working. The error is the same.

My guess is, that this could be some sort of IE setting, because we had this error before:
Capture2.PNG

This error was solved by enabling Protected Mode for internet sites.

Any further Ideas?

Dario B Atlassian Team Mar 12, 2021

@Steffen Sunderdiek ,

Could you kindly translate the error message to english and let me know the date, time and timezone you have done this, so that I can check if I can find anything in your Jira logs?

Can you also confirm that your instance is  kn********rk.atlassian.net?

 

@Vitalii Saienko , Have you seen the above replies? Any idea?

@Dario B :

I'll try, although the last error is resolved by enabling Protected Mode in IE.

"ADD-IN ERROR - This add-in could not be started. Close this dialog to ignore the problem or click "Restart" to try again."

 

I just reproduced the error.

 

Current date/time/timezone:

03/12/2021 11:56 timezone UTC+1 (Germany)

Dario B Atlassian Team Mar 12, 2021

@Steffen Sunderdiek ,

Just to make sure I understand correctly, is the issue solved after enabling protected mod in IE?

Also, are you facing any other issue or everything is now working fine after enabling protected mode?

-in error, that was resolved by enabling protected mode. Now we have the error shown in the initial post.
This error is NOT solved.

Hi @Steffen Sunderdiek ,

I could not  find any error or any line related to the add-on in kn********rk.atlassian.net logs.

Now, it can be the case that the error is actually returned on MS side, but I cannot really determine this by looking at the first screenshot attached to this thread, as well as I cannot see the full stack-trace.

Therefore, we have 2 options to proceed: we can either wait for @Vitalii Saienko to also provide his feedback and, in the meanwhile, you will provide the full stack-trace and more details on how and when you get the error, or, since you are site admin of a JSM site having standard license, you can create a support request using below link in order to have this issue further looked into (select Jira Service Management as the affected product or you won't be able to create the support request):

 

Please let me know how you prefer to proceed.

 

Cheers,
Dario

We can wait for Vitalii first

What I basically do is click in an email I want to create an issue of, selecte create issue from the menu and after a short loading time get the error:

Oops!
Something went wrong while loading add-in. Please try again later or contact support.
Error details

{
"message": "An internal error occurred in the Microsoft Internet extensions\r\n",
"description": "An internal error occurred in the Microsoft Internet extensions\r\n",
"number": -2147012892,
"stack": "Error: An internal error occurred in the Microsoft Internet extensions\r\n\n at r (https://atlassian-outlook-integr.services.atlassian.com/30.617203c9.js:103:68882)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/30.617203c9.js:103:69306)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/30.617203c9.js:103:69270)\n at o (https://atlassian-outlook-integr.services.atlassian.com/runtime~OutlookApp.d5dbcd5a.js:1:550)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/30.617203c9.js:117:145526)\n at o (https://atlassian-outlook-integr.services.atlassian.com/runtime~OutlookApp.d5dbcd5a.js:1:550)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/30.617203c9.js:33:48266)\n at o (https://atlassian-outlook-integr.services.atlassian.com/runtime~OutlookApp.d5dbcd5a.js:1:550)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/30.617203c9.js:117:456057)\n at o (https://atlassian-outlook-integr.services.atlassian.com/runtime~OutlookApp.d5dbcd5a.js:1:550)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/30.617203c9.js:1:113546)\n at o (https://atlassian-outlook-integr.services.atlassian.com/runtime~OutlookApp.d5dbcd5a.js:1:550)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/OutlookApp.eaf853eb.js:75:36627)\n at Anonymous function (https://atlassian-outlook-integr.services.atlassian.com/OutlookApp.eaf853eb.js:35:70891)\n at r (https://atlassian-outlook-integr.services.atlassian.com/OutlookApp.eaf853eb.js:28:50668)"
}

 

I also tried View issues and send to issue with the same result.

Is there any further info I can provide to you?

@Vitalii Saienko : Any Feedback from your side?

Dario B Atlassian Team Mar 16, 2021

Hi @Steffen Sunderdiek ,

The fact that I don't see anything in Jira logs and that the error message says:

An internal error occurred in the Microsoft Internet extensions

Makes me think that the error is on Outlook side and that further investigation is needed. However, this is just a wild guess since I don't see much in the logs and I don't have access to the add-on on your side. 

I have pinged @Vitalii Saienko asking to review this thread again. However, in case of no progress, I still believe that opening a support request is the best way to proceed.

 

Cheers,
Dario

@Steffen Sunderdiek apologies for the delay.

@Dario B yes, this error means that it's the error on the Outlook side, it hasn't started the add-in yet, so we don't send any requests to their Jira yet.

@Steffen Sunderdiek you mentioned in another thread that it works on your local network. Can you confirm that you are using the same email account on both your local and problematic network?

Since this is an error on the Outlook side, I'd suggest contacting Microsoft support as they might know better about this error.

Meanwhile, I found this answer related to IE Protected Mode as you mentioned above. Note, if you've upgraded your Outlook client to Outlook 2019 then it doesn't use IE11 as a renderer anymore, it uses the new Edge browser. I'd suggest doing the same as with IE11 but in Edge.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Bitbucket Smart Commits vs. Genius Commits - What's the difference?

If you already heard about Smart Commits in Bitbucket, know that you just stumbled upon something even better (and smarter!): Genius Commits by Better DevOps Automation for Jira Data Center (+ Server...

106 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you