searching for "-" give error: Unable to parse the text '-' for field '.

Hey

Im trying to search for "-" in a custom text field. But this just resolves in a error:

Search: <custom text field> ~ "-"

Result: Unable to parse the text '-' for field '<custom text field>.


Can anyone help me. Th eproblem is that this is a mandotory field. But sometimes users just put "-".
I now want to find these issues.

1 answer

1 vote
Yew Teck En Atlassian Team Jun 05, 2013

"-" is a special character and you would need to escape it using a backslash. You can try the search with "\-" instead.

For more information, you can refer to this section of documentation: https://confluence.atlassian.com/display/JIRA/Performing+Text+Searches#PerformingTextSearches-Escapingspecialcharacters:\or\\

"\-" gives me this error:

Error in the JQL Query: '\-' is an illegal JQL escape sequence. The valid escape sequences are \', \", \t, \n, \r, \\, '\ ' and \uXXXX. (line 1, character 26)

Per the documentation that was linked to, when doing advanced search you need to use two slashes, i.e. column ~ "\\-"

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Thursday in Jira

Updates to jira.atlassian.com give you visibility into what's coming in Jira Server and Data Center

Hello, Community! My name is Gosia and I'm a Product Manager on Jira Server and Data Center here at Atlassian. Since 2002 when we launched our public issue tracker, jira.atlass...

371 views 1 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you