Why can't a specific user see any issues in search results?

JIRA 4.4

One specific user is getting "No Issues Found" for all filters. For example when logged in as this user, if I query reporter=<username> or reporter=current user(), I get no issues found. When I run the query from my account, I see 746 issues. Logged in as the problem user, I can open the individual issues and see her user is the reporter. I just can't see them in filter results. 

No one else is experiencing this problem and I reindexed just to be sure but it didn't solve the problem for this user. AFAIK, no changes were made to her user and I verified her user is configured exactly the same as users that are working correctly. I'm at a loss to what to look for next. Does anyone have any ideas what else I can check?

 

Thx,

Kathy

4 answers

1 accepted

Accepted Answer
0 votes

Well, whatever it was, it resolved itself when we upgraded to 5.0

Have you tried the Permission Helper?

Go to a ticket you see (and she can't) and click on 'Admin' dropdown...

Thanks but seeing the ticket details isn't the problem. It's the filter results that are empty. Also, I don't think I have that option in 4.4 (sad)

Sorry to hear it. Don't know if there's a Permission Helper in 4.4, but if a user don't have permission to view a ticket, I believe it is excluded from any filter output, etc.

I'm hoping to bump this back up. I now have 3 users experiencing the same problem and nothing I have tried is helping. Because of the symptoms, filter results are blank but users are able to view issue details of issues that should be in the filter results, I am thinking the problem has to do with the users not being recognized as having Browse Projects permissions that they should have. I tried creating a temporary group, adding these users to it, and adding that group to Browse Project in the permissions scheme but that didn't make any difference. I also tried adding the individual users to Browser Projects in the permission scheme for the project and that didn't help either. 

This problem started happening the day after we upgraded from 4.4.4 to 4.4.5. Does anyone know if there were any changes between those versions that could have impacted individual users? 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

469 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you