Unable to connect to JIRA server.

I could not use JIRA today because Server indicated that the JSU license expired. We have been using the free add-on for a long time.

So I upgraded Java Suite Utilities (JSU), and purchased a license. I had been using an evaluation license.

Then I installed the license. Then it asked me to reindex, which I did.

I logged out of JIRA.

Later I tried to log back into JIRA.

Now I cannot login to JIRA at all.

I rebooted the server, to no avail.

I stopped and restarted the Jira service, to no avail.

Our server is running on a Linux Server as a standalone JIRA server.

What do I do now?

1 answer

0 vote

What does the log say the problem is?  Start with <jira home>/logs/atlassian-jira.log

Today was a JIRA nightmare.

I figured that the update to JSU was not compatible with the version of JIRA I was running, 7.4.3.

So I downloaded the latest JIRA, and of course the nightmare got worse.

I backed up everything, the database, the install directory, and the home directory.

Then I changed the atlassian-jira-software-7.7.0-x64.bin file to make it executable. Then I ran it. It failed, even though I said to update an existing installation. I had to delete the install directory. It installed, but permissions and ownership of both the Jira home and install directory were now wrong. Changed them to Jira:jira. Then the database tool wasn't compatible with our version of MySQL. So I had to restore that driver. Then I couldn't start Jira, from Linux services GUI, wrong owner. Not sure but I think the JIRA directories need to be owned by root. Will deal with that later. Then I had to modify server.xml 'path', because we run out of jira directory and not "".  Of course I had to change the port, because we cannot use 8080. Then I couldn't remember the Jira database password, or where the config tool resided. Figured that out. I am not a Linux guru by any means, but Jira 7.7.0 is now up and I can get to the JIRA via HTTP. Still having license issues. Health check fails. Just not my day. If I could figure out how to eliminate the need for JSU I would, because this was a total nightmare! If it wasn't compatible with 7.4.3, it should have not updated.  I was going to update JIRA anyway, just did not plan on having to do it today.

If you thought an update was not suitable, why not just roll it back to the previous version?

There are some ways to get rid of the JSU - start with a look at what you're actually using it for, and see if you can identify alternative methods.

Also, I couldn't get to the add-on manager, because JIRA wouldn't come up. I believe my solution worked, update JIRA. Whew, am glad that's over with. I didn't think about how to back out add-ons from the command line. Thank you once again for the advice.

There are ways to do it without the system even running!   I would have downloaded the old one, uploaded it, gone to the <jira home>/plugins/installed-plugins directory, removed the broken one and moved the old one back in, and restarted Jira.

That is quite an obscure trick of course, and one that you probably only work out after living with too many failed updates and upgrades.  I'm not sure google would have got you there faster than what you've done.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

89 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you