Problem Integrating JIRA and Confluence

I had integrated JIRA and confluence by app, I follow step by http://www.jennywatson.net/2011/03/30/integrating-confluence-and-jira/

I select recent jira issue or add isue well, but search issue in confluence error.

Error message is : "Recieved the following HTTP error code from the server:0'".

PS: step

1. Add an application link in JIRA

  1. In JIRA, from the Dashboard, click Administration.
  2. Select JIRA Administration.
  3. Click Application Links.
  4. Click Add Application Link.
  5. Follow the instructions in the wizard.

2. Link a JIRA project to a Confluence space

  1. In JIRA, from the Dashboard, click Administration.
  2. Select the project.
  3. Click Configure Application Links.
  4. Click Add Link.
  5. Select Confluence.
  6. Select the space.

I’ve already created an issue in JIRA, so now I want to pull that issue into my Confluence page.

3. Display a JIRA issue on a Confluence page

  1. In Confluence, find the page where you want to add the JIRA issue.
  2. Click Edit.
  3. Click the Insert JIRA Issue icon.
  4. Select the issue.
  5. Click Insert.

7 answers

1 accepted

I believe that the BaseURL could be wrong, could you please go to Confluence and Browse > Confluence Admin > General Configuration and check if the BaseURL matches the URL that you're trying to access? Also try to find the BaseURL in JIRA side, making the same changes, BaseURL matching the URL.

If you're using proxy, maybe JIRA cannot reach Confluence. For that I would suggest to bypass the proxy and try again.

I hope this helps.

Cheers,

WZ

I am sure the BaseURL is right.

Confluence and JIRA are deployed in a same server.

0 vote

Firstly, which version of Confluence and JIRA that you're trying to integrate?

Secondly, I would recommend you to refer to our official documentation at the following link.

https://confluence.atlassian.com/display/DOC/Integrating+JIRA+and+Confluence

Hope this helps

JIRA 5.2.x

Confluence 4.3.x

Hello.

I have the same problem. JIRA 5.2.7, confluence 4.3

Same issue here too, with JIRA 5.2.4 and Confluence 4.3.7.

I've double checked the base URL, as well as deleting and re-adding the application links. Other sources indicate the specific versions of the AppLink Plugin might have issues, and upgrading to Confluence 5 may potentially fix it... haven't seen anyone confirm it yet however.

The transition to version 5 doesn't help. And now I have the other Error: Received the following HTTP error code from the server:504

I have this same problem.

I work on JIRA v5.2.4, Confluence v5.0.1.

BaseURL is correct.

Jira and Confluence works on the same server.

Try to turn on the oauth authentication in both JIRA and Confluence.

In JIRA go to Application Links click Edit -> Outgoing Authentication -> Oauth and click Enable.

The same steps for Incoming Authentication in JIRA.

Also you should do the same in Confluence.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

365 views 4 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you