Jira "create sprint" tab is grayed out with some filter queries.

I have a query as below in my scrum board filter:

assignee in (abc, xyz, jkl) AND status in (New, Open, "In Progress") ORDER BY Rank ASC
  • It gives me issues list with no any error.
  • I SAVE it and go under Plan board (under scrum board), i found the "Create Sprint" tab is grayed out.
  • Again, when i change my filter to:
assignee in (abc, xyz, jkl) AND status not in (Closed, Verified, Defect, Pending) ORDER BY Rank ASC
  • than it works like charm. The "Create Sprint" tab is available. For some reason, JQL didn't like "Status in".
  • I am not sure what is wrong with my first query. I have two accounts- regular user and admin user. I am getting this issue with my regular user account.

4 answers

1 accepted

I found the actual cause of this issue.

We have many other projects that has the same status shared. So I believe, the user must have to be the admin of all the projects which uses that status.

Actually currently to create sprint you need "Administrate project permission". https://jira.atlassian.com/browse/GHS-5035 - as you see request ticket is open. So the actual problem is in second request - that user who cannot administer get potential possibility to create sprint. See https://answers.atlassian.com/questions/164780/greenhopper-create-sprint-permissions . Please try to give user administer project permission to projects that are potentially covered by the query so he will be able to create sprints anyway...

PS. My astral guess - you have a set of projects - some of which user can administer, some not. You have the workflow that has one of the statuses listed in the first query and it is linked to the project user cannot administer. When you use second query - jira mistakenly limit the query analisys to the list of project that contain (all of / one of) statues in the query - and the project that user cannot administer is not inside the scope(i.e. it has only New, In Progress, Done statuses). But it will arrive in the query itself, so you've cheated the system )

Thanks Alexey! The problem is actually with one of our Developers. He is having the same issue and i was testing with my regular user account.

I checked the admin previledge, and he is already in the admin role for all the projects.

bq. PS. My astral guess

I think your guess does make sense to me, but its not so clear to me. I tried to check the workflow conditions to see if we have added any retrictions for certain user but it is all clear.

Can you please clearify me more?

Here i found the workaround!

When i add the project list in the query, the "Create Sprint" tab appears to work fine.

assignee in (abc, xyz, jkl) AND <strong>status in</strong> (New, Open, "In Progress") And Project in (jkl,fgh,asd)ORDER BY Rank ASC

Still not sure, why it didnt like only with assigne and status!

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,888 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot