Jira imap mailbox issue create or comment not working

Hi,

On just one of our mailboxes it appears that recently the create or comment on issues seems to not be working. Please see a snapshot from the logs, and note that it appears on only one mailbox. I have confirmed the mailbox settings, IE authentication, port, imap IP address and such. Can anyne shed some light on this?

avax.mail.FolderClosedException

at com.sun.mail.imap.IMAPMessage.getProtocol(IMAPMessage.java:149)

at com.sun.mail.imap.IMAPMessage.getHeader(IMAPMessage.java:715)

at com.atlassian.jira.service.services.mail.MailFetcherService.run(MailFetcherService.java:175)

at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:61)

at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:48)

at org.quartz.core.JobRunShell.run(JobRunShell.java:191)

at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:516)

2012-05-18 10:35:55,526 JiraQuartzScheduler_Worker-1 ERROR ServiceRunner UK EMS Support_AUTN [service.services.mail.MailFetcherService] UK EMS Support_AUTN[10202]: Exception: null

javax.mail.FolderClosedException

at com.sun.mail.imap.IMAPMessage.getProtocol(IMAPMessage.java:149)

at com.sun.mail.imap.IMAPMessage.getHeader(IMAPMessage.java:715)

at com.atlassian.jira.service.services.mail.MailFetcherService.run(MailFetcherService.java:175)

at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:61)

at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:48)

at org.quartz.core.JobRunShell.run(JobRunShell.java:191)

at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:516)

2012-05-18 10:35:55,526 JiraQuartzScheduler_Worker-1 ERROR ServiceRunner UK EMS Support_AUTN [service.services.mail.MailFetcherService] UK EMS

Any help is appreciated!!

2 answers

1 accepted

Accepted Answer
2 votes

I have a slightly wobbly old memory of seeing this error before, although it wasn't in Jira. The message you're getting is actually telling you that the email server is refusing access to the IMAP folder you're trying to scan. The exact reason, I can't tell you, although I remember the email server logs telling us what it was doing. It was timeouts or someone renaming something, I think. Check the config on the mailbox, ideally, compare it with one that is working ok.

Can you provide more information about this, I do have the same problem and I'm sure that the mailbox is fine. How am I supposed to compare the configuration of two mailboxes, I'm not Exchange admin and the mailbox is just fine, it works with any other IMAP client!

I'm afraid that's the problem - I had to hand it over to an Exchange admin to debug it.

What was the cause?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

24,161 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you