Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira dashboards display blank in Chrome

I have a few users with intermittent issue displaying their jira dashboards in Chrome. When they select a dashboard it will just display a blank screen.

You can still see the sidebar listing all of your dashboards on the left side of screen. It is just the dashboard itself that is not displaying.

  • They can click from dashboard to dashboard and eventually they will display correctly. 
  • Clear Local Storage and Cache. Will work until you close Chrome & reopen jira again. 
  • Set Chrome to default settings and still see the problem.
  • It is multiple different dashboards that use different gadgets.

Everything works fine in Edge. It is just Chrome where you see the problem.

Chrome version 97.0.4692.71

Our Jira version is v8.13.14

17 answers

Same here, Jira Data Center 8.13.9 chrome version 97.0.4692.71

keyboard F5 makes dashboard working again without closing and reopening browser.

Disabling cache in developer mode (F12) network tab seems to void this, so it seems if its too slow in loading it may fail (at least on my end).

very random for some reason

We saw that too. Not really a practical workaround but good info to share. 

FWIW I don’t see any evidence that it’s related to the time it takes to load the dashboard. When it happens it impacts all dashboards regardless of content. 

I opened a support ticket and they told me to disable all extensions, so I created a new chrome profile with no extensions and it seemed fairly reliable (not 100% though), but then I opened up the DevTools and ticked "Disable cache" and then it pretty much fails every time after that. But unticking it, makes it work again.

I suspect it might be some sort of timing issue with the order that the script or other resources load in, maybe some event fires off before the script to handle it exists or something weird like that.

I think having extra extensions could cause it to fail because they slow down the rendering of the page, and then scripts get out of order.

See a gif of what it looks like for me.

jira-dashboard-broken-redacted.gif

Like DB likes this

The support agent raised a jira issue for me, after he was able to reproduce by disabling the cache.

https://jira.atlassian.com/browse/JRASERVER-73196

If people can upvote that issue, that will be helpful.

I realise the ticket is a bit more narrow than it should be, but at least someone at atlassian can reproduce the issue.

Like DB likes this

Now that Chrome 97 is rolling out, the complaints from our users are increasing. As I commented in the ticket, we couldn't reproduce the problem by simply disabling the cache. For us it has something to do with permissions.

For me it's even the opposite to what you described. As soon as I disable the cache, the dashboards are working again!? Please have a look at the gif. If you can see I had to reload twice to trigger the issue. So it is a bit random..

Jira Dashboard Bug.gif

Like # people like this
Ryan I'm New Here Jan 18, 2022

Also seeing this - disabling cache, dashboards function as expected. With the option unchecked, the issue re-occurs. 

Like DB likes this

Thanks for the updates Matthias/Ryan.

Disabling the cache certainly isn't the root of the problem, it just so happened to work for me and the support agent. It doesn't surprise me that it's the opposite for you both. When I did my deep analysis yesterday the main thing I took away from it was that it was a timing/event ordering issue. Which means that it'd be dependent on many things, speed of PC, internet connection, speed of server that jira is running on, etc.

One thing I noticed a few days earlier is that the html of the dashboard was essentially the same for when it was working and when it wasn't, aside from a few CSRF tokens in the URLs that were changing.

Matthias, when you change what groups a user is in, it wouldn't surprise me if some of the URLs in the HTML change with a new "cache bust" number, to force them to redownload some new settings, which then affects the performance of the page, even if very subtly.  When you were messing with permissions would it stay working when you changed the users groups around? Or would it only work for a few reloads before failing again?

I also noticed I would have to hit reload twice sometimes too. If you have the opposite of me then the first reload would be downloading the asset again, and the 2nd reload would come from the cache, which is faster and must avoid the issue for you.

Matthias, I looked at your gif more closely and I could see you are using Atlassian's own instance of Jira: https://jira.atlassian.com/secure/Dashboard.jspa

When I tested on there I actually got the same behaviour you were mentioning, "Disable cache" makes it more reliable, and using the cache makes it unreliable. It's about 50/50 for me at the moment.

The Jira instance I was testing with is on-premise, so it has very little latency but with the official Jira on the Internet has more latency so it behaves differently with this issue.

Like Matthias likes this

Joel, Thank you for your deeper analysis of the issue. A timing/event ordering issue makes perfect sense and I was thinking the same as I started playing around with it.

Once a user in our environment has admin permissions, it can be that dashboard-specific permissions may no longer be checked.. Therefore, the loading will be faster and the timing issue will no longer occur.

To answer your question: Whenever the test user was in the jira-administrator group, the issue never occurred. After I removed the user from the group, the issue reappeared immediately and stayed that way.

In my case it turned out to be one of the ReactDevTools extensions. 

Best suggestion, try it in Incognito mode, if it works ,than you need to figure out which extension causes you a troubles. I did it by turning them all off, and turning them on and reloading the page. 

Hope it helps. 

This was the fix for me as well, deleting ReduxDevTools and a hard refresh fixed the issue. Thanks!

Like Faizal Amiruddin likes this

This actually improved the situation for me too. It still happens sometimes, but now it works a bit more often for me with React Developer Tools disabled.

It works, for me I only turned off redux devtool extension. But I still wonder, why this happened

This is the answer. 

The guys over on the redux projet know about this and a fix is available as of this morning.

thread: https://github.com/reduxjs/redux-devtools/issues/1032

 

TLDR; "You can force an update from the extension page" 

I have this issue with Jira Service Desk Data Center (4.13.9) On Prem with Chrome Version 97.0.4692.71 .

And i do not have Redux Devtool Extension installed.

Same problem with 8.20.3 and Chrome 97.0.4692.71

Same issue with us.  Jira 8.13.8. 

Chrome Version 97.0.4692.71 (Official Build) (64-bit)

First dashboard works, 2nd, 3rd, and so forth are blank.

Ctrl-F5 fixes it temporarily, but it comes back.  Happens on Macs too.   Edge works on Windows.  Safari works on Mac.  

2 votes

Same issue with same version of Chrome 97.0.4692.71, but different Jira version 7.13.3.  Corporate IT controls the browser version, so upgrading that is at their mercy.  Behaviour started only recently, approx Jan 11 2022.

If you want a workaround in your local Chrome (not a server-side fix), I've written a small user script that triggers the dashboard to render if it detects the dashboard hasn't rendered.

See my comment on the main jira issue.

I think this is only a temporary solution (because what is better – using JIRA in other browser or always disabling an extension you otherwise need when working with JIRA :D?), but go through your extensions and try to disable all of them. If you refresh JIRA, it might work. Then you can go 1-by-1 with your extensions and turn them on – always refreshing JIRA afterwards and find the one that caused the problem.
Pray it is not an important one :D...

btw, it was Redux DevTools

I hope some people get relief from disabling add-ons.  It has not helped me or any of the users who have reported the problem.

That's exactly what I just did and it worked)

I originally had no extensions installed and still found the issues but were utilising an on-prem Jira server, very bizarre random errors.

Could it be useful if some Atlassian Representative opens an issue on Chromium ?

Same issue here

Jira 8.21.0
Chrome Enterprise 97.0.4692.71

Works in Microsoft Edge, and seems to be a Chrome and Chrome Incognito bug but more stable in Incognito mode

1 vote
Jack Brickey Community Leader Jan 13, 2022

Maybe you could try a different version of chrome? https://chromereleases.googleblog.com 

Just updated to Version 97.0.4692.99 (Official Build) (64-bit)

Issue still present for me (Jira Service Desk Data Center 4.13.9 on Prem)

0 votes

I had the same issue with Chrome 97.0.4692.71. It disappeared after updating to 97.0.4692.99.

Issue still present for me, just updated Chrome to Version 97.0.4692.99 (Official Build) (64-bit)

I updated, and it went away for a few minutes, but then came back.

Jira Data Center 8.13.8

Still present in Chrome Enterprise 97.0.4692.99 for me

0 votes

I got it it's plugin issue for me i disable Redux Dev Tool and it works

0 votes

Happening here as well. Only one user having the problem. Yesterday was fine, today he cannot see anything on the board, but can get to the issues in other ways. We are not having this with any application other than Chrome and it just started. 

same problem but disabling or enabling cache does nothing for me

not sure if there was any update on Jira side, but after Chome updated to 97.0.4692.99 the problem is gone

Still fails with our on prem Jira here

Chrome enterprise 97.0.4692.99
Jira v8.21.0

Has anyone had a chance to compare whether the issue exists in both the 32 and 64 bit versions of Chrome 97?

Interesting question, I am running the following if anyone is seeing the same issue in other versions:

Recently updated today 
Chrome Enterprise 64-Bit -  97.0.4692.99

Same issue as 97.0.4692.71

I have the same issue on Chrome/97.0.4692.71

 

Any Boards/backlog appears as a blank page to me. All other sections of the app loads correctly.

 

Edit: It was Redux dev tools extension conflicting with JIRA.

As additionnal information, I have 2 colleagues that are on MacOS 12.0.1 with Chrome/97.0.4692.71 and they can see the dashboards fine.

I am running MacOS 11.6.2 with the same Chrome/97.0.4692.71 and can't see the dashboards.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you