Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issues not showing in Releases/Version despite having a Fix Version

I am on Jira Cloud and created a version. I added an issue to that version while in the backlog and the version showed up in the row. The issue also displays the associated version in "Fix Versions" field.

After adding it to the version, I can click on the Version in the backlog and it will filter correctly.

If I refresh the page at this point and click on the new version again, it is no longer there. The issue still has the version associated with it, but it does not show up in the filtered backlog. The issue does not display under the Releases page either.

The only possible resolution I could find was to re-index my instance manually but it appears that option has been deprecated for Cloud, so I am not sure what to do now.

2 answers

Hi @Kassidy Hall 

Just to confirm, the steps I took to reproduce were:

  • Went to a Board (I used a Kanban Board)
  • Drag/Dropped an issue from the backlog into a version in the panel
  • Viewed the issue using the version as a filter - and saw it tagged as a label on the issue in the backlog
  • Pressed refresh
  • Viewed the issue against using the version as a filter - and it's also in the Releases page

It sounds like the last bullet point isn't working for you.

Is this happening for all issues or just this specific one? And is it just an issue on that one board?

It would be great if you could provide a screenshot of the issue in the backlog with the version name label, alongside screenshots of the filtered view and the Releases page for that version! This will help us analyse the specific issue.

Ste

Hi @Stephen Wright _Elabor8_ ,

For what it's worth, I am using a classic Scrum board, and yes - those are basically the same steps I am performing. It happens on any issue with that project. I just tested it on another Scrum board and the same behavior is there too. 

I did have the "Fix versions" and "Affects version" fields hidden in the Field Configuration when I originally created a version for the first time. The same behavior (where the issue would display as being added to the version, but not persist) was happening but I couldn't see the "Fix version" field to verify it was actually being added. That is when I went in and clicked "Show" on those field configurations.

At first I thought maybe that was affecting it, but the same behavior persists even on the other board after creating fresh versions even after enabling/unhiding those fields.

Please see the attached GIF for exactly what I'm seeing.

Jira-Versions-Glitch.gif

I'm not sure which of the following resolved it, but I did these steps:

  1. Tools > Issues > Field Configurations > Default Field Configurations
  2. For "Fix versions" and "Affects version", I toggled Hide/Show (meaning I hid the field, waited a few seconds, and immediately clicked Show)
  3. I set the Active Renderer for "Fix versions" to the only other option which was "Select List Renderer" and saved the settings.
  4. I came back to the Active Renderer settings again and chose "Autocomplete Renderer" and saved the settings

I assume "Select List Renderer" is not an actual option, but it seems like toggling this option fixed it. It could have also been toggling between Hide/Show.

Like # people like this

Awesome, glad you fixed it :)

Thanks for posting the steps you took - hopefully this will help other users who face this issue in future!

Ste

So ridiculous that a hidden field causes expected functionality to just not work... apparently hidden means disabled?

THANKYOU .... 

This is a user experience FYI ATLASSIAN 

There is no point allowing a user to config in the issue screen when if the FIELD CONFIG over rides this ! 

Screenshot 2021-01-04 at 17.14.54.png

e.g. set FIX Version in my issue config view to show BUT it couldn't be seen as the ACTION in the FILED CONFIG has it as HIDE Screenshot 2021-01-04 at 17.14.40.png

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you