Issue ID Exception In Jira Logs.

Hi Team,

My Jira Application is workin fine, but in logs I'm observing below exception.

When I'm navigating to Issues In logs it's throwing below error.

2013-12-17 05:20:20,655 TP-Processor93 WARN amber.garg 320x1155251x1 1f6dw07 172.20.11.143 /secure/IssueNavigator.jspa [velocity] org.apache.velocity.runtime.exception.ReferenceException: reference : template = getEncodedBodyFromContent [line 1,column 34] : ${issue.id} is not a valid reference.

at org.apache.velocity.runtime.parser.node.ASTReference.render(ASTReference.java:277)

at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:230)

at org.apache.velocity.app.VelocityEngine.evaluate(VelocityEngine.java:300)

at org.apache.velocity.app.VelocityEngine.evaluate(VelocityEngine.java:202)

at com.atlassian.velocity.DefaultVelocityManager.getEncodedBodyForContent(DefaultVelocityManager.java:143)

at com.atlassian.jira.plugin.webfragment.JiraWebFragmentHelper.getHtml(JiraWebFragmentHelper.java:111)

at com.atlassian.jira.plugin.webfragment.JiraWebFragmentHelper.renderVelocityFragment(JiraWebFragmentHelper.java:102)

at com.atlassian.plugin.web.model.DefaultWebLink.getRenderedUrl(DefaultWebLink.java:35)

at com.atlassian.jira.plugin.webfragment.model.JiraWebLink.getRenderedUrl(JiraWebLink.java:34)

at com.atlassian.jira.plugin.webfragment.DefaultSimpleLinkManager.convertWebItemToSimpleLink(DefaultSimpleLinkManager.java:274)

at com.atlassian.jira.plugin.webfragment.DefaultSimpleLinkManager.getLinks(DefaultSimpleLinkManager.java:194)

at com.atlassian.jira.plugin.webfragment.DefaultSimpleLinkManager.getLinksForSectionIgnoreConditions(DefaultSimpleLinkManager.java:141)

at com.atlassian.jira.plugin.webfragment.DefaultSimpleLinkManager.getLinksForSectionIgnoreConditions(DefaultSimpleLinkManager.java:146)

at com.atlassian.jira.web.action.issue.IssueNavigator.getIssueOperations(IssueNavigator.java:2004)

at sun.reflect.GeneratedMethodAccessor1208.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

Thanks

Amber

1 answer

1 accepted

Thanks Chritsian How I can find which plugin is causing this as recently I've not installed any new plugin.

Thanks

Amber

I would check if all plugins are up to date. Other than that you could test it by disabling one by one and monitor the logs...

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 7 hours ago in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

86 views 4 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you