How to apply a permission scheme to a project? (can't find 'Permissions' under Project Settings)

Ozan May 14, 2024

I have a project that I'd like to make visible to the public.

I've changed my Default Permission Scheme, granting 'Browse Projects' permissions to 'Anyone'. I've also changed my Project Access to 'Limited'. With this, anyone should be able to view the project, but only users who've been added to the group can make changes.

However, this is not the case. When I try to view my project in an incognito tab, I'm still prompted to log in; when I log in, I'm told I don't have access to the project.

I've noticed that in the permission schemes page, my project isn't shown under the 'Projects' column of my Default Permission Scheme, meaning it isn't applied to that project.Screenshot 2024-05-14 164657.png I've searched online for instructions on applying a permission scheme, but all guides say that I should go to Project Settings > Permissions, however my project settings tab doesn't have a 'Permissions' option (pic attached).

Screenshot 2024-05-14 164636.png

Any suggestions? How can I solve this issue?

 

1 answer

1 accepted

1 vote
Answer accepted
Chris Rainey
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 14, 2024

Hi Ozan,

You're in a team-managed Jira project. Permission schemes can only apply to company-managed Jira projects.

In a team-managed project, to configure that access, you'd go to the "Access" tab in the project settings menu.

Ozan May 14, 2024

Hello Chris,

Thanks for the quick response. I've tried setting my Project Access setting to both 'public' and 'limited', but in both cases I'm still unable to view the project unless signed into an account with an assigned role.

Any suggestions?

 

Chris Rainey
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 14, 2024

Hmmmm.

I tested in my sandbox and I was able to get this to work by setting the project access to Public and by making sure the user account I tested with had access to the sandbox site. 

The account you're testing with is able to access the site?

Ozan May 14, 2024

>and by making sure the user account I tested with had access to the sandbox site. 

I think that's where the issue arises; the site I'm using was created today, specifically for this project. In other words, the site settings are still set to default.

The account I'm testing with does not have access to the site; when signing in, I receive this message:

"{email} doesn't have access to Jira on {domain}.atlassian.net."

 

Chris Rainey
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 14, 2024

Ah, so that may do it. Try granting it access, setting the project to Open (Public), and see if that solves for it.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events