Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I escape a backslash "\"?

I've used the backslash to escape most other special characters.  However, when I tried to escape a backslash, the expected "\\" was converted to a newline.

1 answer

Hi @Aaron Grosky ,

 

As far that I know you don't need to escape backslash "\"; You can go ahead and just use the backslash character.

I've tested in a JIRA description and I had the following result:

using \ resulted in \

using \\ resulted in a newline as you mentioned.

If my answer don't answer your question, please share with us step-by-step with your issue.

@Italo Qualisoni _e-Core_  Maybe a misunderstand.

As the AG said,  the expected "\\" was converted to a newline.

 

I raised the similar jira questions earlier: https://community.atlassian.com/t5/Jira-questions/How-do-i-input-quot-0-quot-and-quot-0-quot-in-JIRA-comments/qaq-p/1562170, no response yet.

If you want to have \\ you should type \\\\

 

use \\\\  results in \\

@Italo Qualisoni _e-Core_

@Wu Chen did not misunderstand me.  I tried to highlight a backslash, e.g. "... use a \ to ...".  *\* becomes ** and *\\* becomes two stars separated by a newline.

For consistency, any special character following a backslash should have its meaning changed.   \\ should make the second \ a printable \.  \@ should not complain about the text which follow it (an unescaped @ is not a problem since it formats correctly).  \newline should be the way to force a newline (change the newline from white space to a required newline).

IMO, both \\ and \@ not escaping the second character are bugs and should be fixed.  If \\ is a documented way of forcing a newline, then fixing this may be difficult because of backward compatibility.

It's documented here that \\ produces a new line:

https://jira.atlassian.com/secure/WikiRendererHelpAction.jspa?section=breaks

Now it's clear that you want to produce \ (bold \ character) using wiki markup.

Using the new WYSIWYG editor I can make it work and see in issue history *\\* is used. But if I try to create an issue using *\\* in the description, the issue description stay empty.

issueview.png

This might be indeed a bug and I would recommend open an issue to Atlassian support in https://support.atlassian.com/

Actually, the Atlassian documentation conflicts.  In one section, the \\ is clearly documented as creating a line break.  However, in another section the \ is said to remove the special properties of the following character.

As to the WYSIWYG editor, this is the first I've heard of it.  That may be a new feature that is not yet available where I work.

Yep, expected \\ characters (0x5c, 0x5c in ASCII) always can not be showed in JIRA comments.

I'm not sure why this rule exists, remove this "\\ creates a line break" limit, in fact, at least it's not bad .

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you