Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,527
Community Members
 
Community Events
165
Community Groups

How can I remove "create project" for user

I added a new user and assigned him to a project. Only this one project is showing but the user can create new projects. I want to remove that permission. How can I do that?

1 answer

1 accepted

0 votes
Answer accepted

Hi @Leonido Gebhard ,

You need to remove Create independent projects permission from users, for more information you can go through the Managing global permissions page.

Regards,
Kishore Kumar Gangavath.

Hi @[deleted] 

 

Thanks for your answer. I found this in another answer but was not able to locate where to change this.

I went ahead and allowed "create nex-gen projects" only for administrators. That worked as well. Can you point me to the location where this can be done "Create independent projects permission from users"

 

havent worked with jira for a long time and never had to administrate users then.

Like # people like this
Deleted user Jun 21, 2019

Hi @Leonido Gebhard ,

Remove that user from the JIRA administration group or administrators group then that user will not be able to create a project. To do this go to the Global Permissions page and verify what are all groups are added to the JIRA administration group. Then verify if that user is a part of any of the groups. If that user is present then remove from that group. To perform this you need the site-admin permission.

Regards,
Kishore Kumar Gangavath.

Hi @[deleted] 

 

Thank you for your reply. I already checked the groups in Settings -> User management -> Groups

The user was not to be found in any of these groups.
Since I removed it from the global permissions, it's no longer showing. Not sure though if this was a good idea.

 

Best regards,
Leonido

Hi @Leonido Gebhard 

I came across this myself just today and just to add to your comments above - I found that this was related to the "create nex-gen projects" global permission which had no restrictions applied at all by default since we migrated to Cloud. 

Changing this to the administrator group only and has resolved this. It was also confirmed with a user that the Create Project button will still appear however now when clicking it will show the different types of projects to the user but not allow any progress past that. 

The users were not in the Administrator group so they did not get this permission there and I also was unable to find "Create independent projects permission from users"

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you