Epic Status configuration

Gary Spross February 24, 2022

I converted a Service Desk project to be a Software project type and added the Epic issue type. I came to realize that in order for an Epic to be complete, the "Epic Status" needed to transition to the "Done" state. I added the "Epic Status" field to my screens so that I could change the state, but no states existed in the drop down. When I view the "Epic Status" field, I see that 2 configuration schemes exist for it. The original (I'm guessing) scheme has no applicable contexts associated with it and the other, which is associated with the Epic issue type, has no options configured.

My questions are:

1. How would this occur?

2. Is there any way to correct this situation?

NOTE: The other Epic fields (Epic Color, Epic Name, etc.) do not have this issue. They all show a single scheme associated properly. They also seem to work as intended.

 

image.png

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Sachin Dhamale
Community Leader
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February 24, 2022

@Gary Spross 

Welcome to the Atlassian Community.

In Software Project - To manage you project task you have 3 status Epic Status, Issue(Story/Task) Status, Workflow Status.

Epic Status - Group of issues(Story/Task) from different project or same project. To indicate the status of all issue on Epic level for that we use Epic Status field. and that is control from Board > Backlog section of the  

Issue Status -Status of Individual issue (story/task)

Workflow Status - Life cycle of issue which is linked with issue status

If you can to make Epic as Done then you can do it from Backlog Section

1. Select the Board

2. Select the Backlog

3. Select the Epic Section

4. Select the Epic Which you want to make Done

5. Click on Done

 

Epic Done.png

Gary Spross February 25, 2022

Thanks Sachin, but therein lies my issue. I don't see the "Mark as Done" option within that dialog. Presumably because the configuration of the "Epic Status" (as shown in the picture in my original post).

So the questions are:

1. How would this configuration issue occur?

2. Is there any way to correct this configuration issue?

image.png

Sachin Dhamale
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 25, 2022

@Gary Spross ,

In that case you are facing issues which is mentioned in this Doc 

I think you are facing the cause 2 issue. Apply the resolution accordingly

 

Cause 1

Each Epic have a 'hidden' Epic Status custom field applicable to it. And the custom field by default have the following values:

  • To do
  • In Progress
  • Done

These values are required to indicate the current status of an Epic. Hence if this values are missing, then the "Mark as Done" option will not appear in the Epic drop down menu.

 

Cause 2

 The Epic Status custom field has multiple contexts setup, causing JIRA Agile to not properly recognize the configuration

 

 

Resolution 1

  1. In order to fix the problem, we can add the options again to the Epic Status custom field
  2. Go to Administration > Custom Fields > Epic Status > Configure, and add the stated options to the field:
    To do
    In Progress
    Done

Resolution 2

Remove the extra context configuration, leaving a default with Global Context selected

  • If the options are missing from this context, please also follow the above steps to add the appropriate options.

 

 

Gary Spross February 25, 2022

@Sachin Dhamale 

Thank you for this explanation. I will need to reach out to my IT department to gain access to our Jira database since the field is locked. I found the following article detailing how to unlock a locked field so changes can be performed against it.

Unlock a locked Jira Software custom field 

Gary Spross March 2, 2022

Just adding a note here to confirm that I was able to run through the steps described in the article linked in my previous comment and successfully fix the configuration issue with the "Epic Status" field.

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Pramodh M
Community Leader
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Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 24, 2022

@Gary Spross 

It's an internally managed field, used for detailed tracking of information on reports, JQL 

You can consider the Epic as closed once it is moved to Done Category from the board panel, you could close the Epic issue as below.

Ep1.png

And the same will be updated in the field you are referring

This value is checked for report generation in Reports

Please refer the Doc here for more info

https://confluence.atlassian.com/jirasoftwareserver0811/working-with-epic-statuses-1019393039.html

Thanks

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