Can't connect my own S3 storage to Jira

Константин Щукин
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 9, 2024

Try to connect S3 bucket to my Jira instance for storing attachments and avatars but got an error


2024-04-09 19:50:36,861+0300 HealthCheck:thread-8 WARN [s.a.a.r.internal.util.EC2MetadataUtils] Unable to retrieve the requested metadata.

2024-04-09 19:50:36,878+0300 HealthCheck:thread-3 WARN [c.a.jira.filestore.FileStoreConnectionCheck] Failed to list filestore healthcheck directory during cleanup: S3Path[path='s3://jira-nt-storage/attachments/healthcheck-9e6073a4-1c9c-4202-af55-f8f53161ba6b', executor=com.atlassian.dc.filestore.impl.s3.OperationExecutorImpl@39cc47b] Unable to load credentials from any of the providers in the chain AwsCredentialsProviderChain(credentialsProviders=[SystemPropertyCredentialsProvider(), EnvironmentVariableCredentialsProvider(), WebIdentityTokenCredentialsProvider(), ProfileCredentialsProvider(profileName=default, profileFile=ProfileFile(profilesAndSectionsMap=[])), ContainerCredentialsProvider(), InstanceProfileCredentialsProvider()]) : [SystemPropertyCredentialsProvider(): Unable to load credentials from system settings. Access key must be specified either via environment variable (AWS_ACCESS_KEY_ID) or system property (aws.accessKeyId)., EnvironmentVariableCredentialsProvider(): Unable to load credentials from system settings. Secret key must be specified either via environment variable (AWS_SECRET_ACCESS_KEY) or system property (aws.secretAccessKey)., WebIdentityTokenCredentialsProvider(): Either the environment variable AWS_WEB_IDENTITY_TOKEN_FILE or the javaproperty aws.webIdentityTokenFile must be set., ProfileCredentialsProvider(profileName=default, profileFile=ProfileFile(profilesAndSectionsMap=[])): Profile file contained no credentials for profile 'default': ProfileFile(profilesAndSectionsMap=[]), ContainerCredentialsProvider(): Cannot fetch credentials from container - neither AWS_CONTAINER_CREDENTIALS_FULL_URI or AWS_CONTAINER_CREDENTIALS_RELATIVE_URI environment variables are set., InstanceProfileCredentialsProvider(): Failed to load credentials from IMDS.]
My instance running in docker
Using a self-hosted S3 object storage minio RELEASE.2024-03-15T01-07-19Z
I tried to set ENV variables AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY but no way and mount filled credentials and config to ~/.aws folder in container but still have the same error
Although I can use aws cli and aws s3api from my container and all is good, I can list bucket, put object and delete it but not from Jira
Can anyone help me, please?

0 answers

Suggest an answer

Log in or Sign up to answer