Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Askpass unable to start correctly

Every half an hour or so I get the following error:

askpass_error.png

Google told me it's related to Atlassian.

I ran Fix Windows Update errors by using the DISM or System Update Readiness tool as recommended by Windoze, but to no avail.

Anyone knows how to solve it - as it's a pain having to keep clicking OK to close it.

Thanks a lot.

16 answers

3 votes

Hi @Tomasz Kotula 

I am unsure how a web product (Jira Cloud) can cause such an error in a desktop application (Askpass.exe).

Can you link that article from Google that says this error is related to Atlassian products?

Sorry my bad. It's caused by Sourcetree. I'm running V3.3.4 and as soon as I closed it the error stopped happening.

Oh okay, I am not much familiar with Sourcetree. Lets wait if someone else is aware of this issue.

i met the same error, who can help this? thanks!

I have the exact same error.

It's still happening to me (only while Sourcetree is running). Can someone chime in?

It's also happening to me for a while now.

Okay my issue has gone recently after > 6 months. This is my story:

- I copied and pasted a project from one of my teammates. That included .git folder, not just code files.

- I opened SourceTree and .. probably changed the credential somehow but I don't remember exactly.

- Then, this issue became consistent since then.

- I closed that project by clicking on the tab in SourceTree and Closed it. The issue was still there.

- 2 years ago, I deleted that project from the file system. The issue has gone.

I don't know for sure if this scenario caused the issue but this is what I experience.

A colleague of mine is also suffering from this irritation. He's using version 3.3.7 of Sourcetree. The dialog pops up periodically whilst he is running Sourcetree. The issue suddenly started occurring last week.I am aware that you don't have much interest in Sourcetree Atlassian, but could you please investigate this?

I have the same problem for many weeks, dozens of times an hour.

I don't know if this helps anyone but I was having the same problem. One of my remote repository's token had expired. Whenever SourceTree was trying to refresh the remote status that Askpass.exe exception would come up. When I found the culprit repo, I forced a connection (i.e. push or pull) which then prompted the Github login box where I entered my username and password which refreshed the remote's token. The dialog box was gone after that.

Never ending stupid message it just doesn't ffn stop

It's happening to me too

still persists in version 3.3.8

I fixed the problem by re-checkout the git repo.

As for Michael_Jan_Gaabucayan, my colleague installed 3.3.8, and the issue has not occurred again since. This may or may not work for others having the same problem. It seems that Atlassian don't care about it otherwise they would be commenting here.

A few days ago I installed 3.3.8 but unfortunately the fault is still happening.

Atlassian can you respond please.

It started happening to me today out of nowhere.  using 3.3.6. Says the is the latest version so not sure how some have 3.3.8

Almost 3 months have gone by and no official comment from Atlassian team...

I have the same issue happening over here and I have tons of repositories in my PC with no clue to which one may be the source if any.

It started happening to me yesterday, and continues even after uninstalling, restarting, reinstalling, restarting...

0 votes
Hoopou I'm New Here Oct 13, 2020

I have the same error and this is very anoying!

same error after trying (and failing) to replace the username/password with PAT (personal access tokens)

tried deleting the sourcetree password file - no joy

cannot get remote repos after entering the new PAT as the password - credentials fails and now the askpass.exe failure message pops up constantly.

 

SOLVED

choosing oauth option instead of basic takes you to a web page. enter your github password and click the authorise button.

 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you