Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,751
Community Members
 
Community Events
168
Community Groups

Askpass.exe application error

I get this popup when running SourceTree 3.3.8. It seems to go away after I push something and login using SourceTree, but eventually comes back after a time. This is reproducible with 3.3.8 and 3.3.4. Any ideas would be appreciated.

Askpass.png

2 answers

1 accepted

13 votes
Answer accepted

I had the same issue after upgrading to 3.3.8

It was resolved after deleting some old accounts and edit the other ones under Tools >> Options >> Accounts

At the same time all my checked out repositories were showing a red exclamation mark on the "Remote" icon.  Clicking on Remote was trowing an error from winscp "Putty.exe not found".
So I installed putty but without success.  The exclamation mark was still there and clicking on the icon was now trowing 'Server refused to start a shell/command'.

Next thing I tried was to do a new Clone and that was working.  So I compared the "Remote Account" settings under Settings >>  Remotes >> origin >> Edit and it seems that for my previously cloned repositories this settings were not correct anymore after the upgrade.  Changing them solved the issue with the Remote.  Clicking on Remote was sending me now to the right repository location in a browser.

Thanks, I deleted my saved password under Tools >> Options >> Authentication, and then the next time I did an action that required authentication, it re-saved my password. The saved password was a little odd looking in that it said "Rest-Saved Passwords" in the dialog, which was different from a co-worker's so it made sense that this might be the culprit. Afterwards, the title changed to"Git Save Passwords". After this, then the problem went away. Thanks!

Like # people like this

Sourcetree doesn't make it easy to delete the passwords. There were around 20 to delete, each one taking several clicks. Hope this works!

Your solution worked for me, too.  Yesterday I had switched over my Github and Bitbucket accounts/repos to the SSH they are now requiring.   AskPass errors ALL day long.

Opened each repo, clicked Settings, double clicked the URL for the repo (to edit the entry), they were all set to "Generic Host" instead of my specific saved Bitbucket and Github save logins.  Switched them to that, and they went away.

The "Generic Host" entry should die.

Like # people like this

Doesn't work for me!

Like Ultroman likes this

I pressed the + button to add a repository tab, and clicked "Remote" to see my remote repositories, and only there did it warn me about a problem, showing a red circle with an X in it on my Bitbucket account. No warnings in my account settings. I tried editing and remaking that account several times, using HTTPS and OAUTH, which succeed, but it returns to having the red mark on it in the "Remote" list after a few seconds. The AskPass.exe error seems to have disappeared. I can pull and push just fine using the account. Not sure what to make of this. It'll probably come back.

Like Will Belden says, manually changing from Generic Host to a specific account seems to take care of the problem, at least for a while. Doing what I did, also seems to make it go away for a while.

It is ridiculous that none of the big players in this (SourceTree, Git, etc.) have any working tips to solve this. It has been going on for years. Why on Earth is anything calling AskPass.exe if it's so obsolete that the file is missing?

Yep, it came back a few days later. I don't even have the broken account or any repositories from it in SourceTree anymore. I guess it's one of the other ones that's broken, but I've already removed them all and readded them several times with different setups, but it keeps coming back.

I had the same error.

I was able to reproduce the error message on demand by going to Repository > Refresh Remote Status.

I then noticed I didn't start Sourcetree as Administrator.

When I restarted Sourcetree as Administrator and then tried to reproduce the issue it didn't occur anymore.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events