Action "CLONE ISSUE" does not work any more

Without any modification of the environment / plugins / installation we see the following behavior:

The action button Issue-xxx -> More Actions -> clone opens a dialog with the (expected) Clone- Dialog (enter summary..), but when I press the create-button no copy is created.

Instead, it produces two links at the same issue (cloned by and clones) which refer to the same (old issue).

No error message appears, it just does not work.

We tried to clone issue with different Issues, different users, in different projects (using different Workflows), but always with same result: no clone is made. But we know that it worked some days ago.

Any hints how to find out what's going wrong?

Thanks in advance

1 answer

1 accepted

0 votes

Does your log file say anything? (Around the time someone tries to clone)

I'm also not sure what "it produces two links at the same issue" - could you explain what issues are at either end of the new links? Maybe a screenshot of the view of the issue being cloned?

Perfect, that confirms that I wasn't misreading what you'd said.

Now that really is an interesting problem. I've no idea how you could get that to happen without coding, but a couple more questions:

  • You definitely are using the built-in standard clone function? No plugins providing an alternative?
  • Does your log say anything that might even be remotely related when someone uses "clone"?
  • What does the issue history say? Are there events for the linking appearing? Anything else that looks suspicious?
  • Bit of a long-shot, but can you check the workflow for this issue type? Look for the "create" transition and it's post functions. Do you have any other than these three standard ones?
    • Creates the issue originally.
    • Re-index an issue to keep indexes in sync with the database.
    • Fire a Issue Created event that can be processed by the listeners.

"it produces two links at the same issue": If I press the two links, I stay at the same issue.

NIc, great questions!

Asking the right questions is 80% of problem solving: With your help I could isolate the problem to this:

In the Workflow transition from Create-Issue to New I had a Post-Validator that a specific custom filed must not be empty. But if someone clears that field later on, then a clone fails.

Ok, that can be seen as a poor workflow, but I would expect some kind of error notification in that case.

So, my problem is solved

Thanks

Gerwin

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,968 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot