Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,556,003
Community Members
 
Community Events
184
Community Groups

The Battle is Won, the Dragon is Slain

Edited
Bruno Costa
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 14, 2019

I completed the Windows quest with a victory and as per the instructions I am now trumpeting my success here in the Community 😊

However my victory was not complete (or perfect): My Bamboo Plan Summary Chart gadget doesn't work on JIRA as I always get "An internal server occurred(...)" error. I tried troubleshooting but could only find solutions that applied to Linux environments and even though I tried to adapt them to mine, I failed.
So I can understand if I don't get a full t-shirt 🙂

Screen Shot 2019-05-14 at 16.32.28.png

That't it...

Regards,
Bruno

3 comments

Jakub Sławiński
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 14, 2019

Hi @Bruno Costa ,

 

can you share some logs?

Bruno Costa
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 15, 2019

Hi @Jakub Sławiński 

I reproduced the problem (adding the gadget again) to get a specific time-frame for the error. With that I found this in the atlassian-bamboo.log:

2019-05-14 14:28:27,496 ERROR [http-nio-8085-exec-2] [ThrowableExceptionMapper] Uncaught exception thrown by REST service: Could not initialize class org.jfree.chart.axis.NumberAxis java.lang.NoClassDefFoundError: Could not initialize class org.jfree.chart.axis.NumberAxis at org.jfree.chart.ChartFactory.createXYBarChart(ChartFactory.java:1493)
(...)

I could not find other errors in JIRA or catalina logs at around the same time. I admit that I didn't search on all log files for messages at around this time.

 

That error lead me to solved BUG BAM-3573 that mentions setting the LD_LIBRARY_PATH EV but by the looks of the value this seems to affect Linux platform so didn’t push further on this. I tried however this other solution found via Google  even though this again applied to Linux (catalina.sh file). I tried adding the option -Djava.awt.headless=true into catalina.bat in the <bamboo>\bin dir and restart Bamboo but still got error even though a different one (so the change in catalina.bat made some impact):

2019-05-14 16:19:07,055 ERROR [http-nio-8085-exec-7] [ThrowableExceptionMapper] Uncaught exception thrown by REST service: C:\Program Files\AdoptOpenJDK\jdk-8.0.212.03-hotspot\jre\bin\awt.dll: Can't find dependent libraries java.lang.UnsatisfiedLinkError: C:\Program Files\AdoptOpenJDK\jdk-8.0.212.03-hotspot\jre\bin\awt.dll: Can't find dependent libraries

 

I wonder if the error is due to having used AdoptOpenJDK 1.8 and not the OracleJDK 1.8 as mentioned in the pre-requisites of the Dragon Slayer. However I installed the AdopOpenJDK due to change in licensing from Oracle and AdoptOpen is the one bundled with Atlassian products...

Jakub Sławiński
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 15, 2019

Hi @Bruno Costa ,

 

can you install AdoptOpenJDK in a directory without whitespaces?

 

Do you have the same issue when using OracleJDK, or you didn't try that?

Like Bruno Costa likes this
Bruno Costa
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 15, 2019

@Jakub Sławiński

Thank you for the suggestion. I uninstalled AdoptOpenJDK and installed it again specifying a new path without spaces (C:\Applications\AdoptOpenJDK).
I checked that JAVA_HOME EV was updated correctly (had selected that option during JDK installation) but then Bamboo service started failing with the error:
The Atlassian Bamboo Bamboo service terminated with service-specific error Incorrect function

I found a couple of Community questions with same error, tried other fixes found online but to no avail.

I didn't try OracleJDK due to their new licensing and not wanting create account using my company's mail.

Jakub Sławiński
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
May 16, 2019

Hi @Bruno Costa ,

 

can you confirm that you you have the same Java exe in your PATH and JAVA_HOME?

 

I found that as a root cause described in https://community.atlassian.com/t5/Jira-Software-questions/Jira-Software-service-won-t-start/qaq-p/848336

Like Bruno Costa likes this
Bruno Costa
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 16, 2019

Thanks for the tip @Jakub Sławiński .

I have the same JDK, although the EVs are not exactly the same as the JAVA_HOME points to the install directory, in my case is now "C:\Applications\AdoptOpenJDK" and in the PATH the value is set to the "bin" subdir, in my case "C:\Applications\AdoptOpenJDK\bin".

I would like to fix this setup, and have JIRA, Confluence, Bitbucket and Bamboo all working fine in my Windows test machine but I don't think I can spend much more time on it now.

Tim Eddelbüttel
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Oct 11, 2019

Today I setup Jira with Adopt OpenJDK 8.0.222 and jira won't start with a similar error.

java.lang.UnsatisfiedLinkError: C:\Program Fieles\AdoptOpenJDK\<version>\jre\bin\awt.dll Can't find dependent libraries...

After a bit of investigation I fixed it by downgrading the Adopt OpenJDK to 8.0.202. The hint comes from a Confluence related KB article: https://confluence.atlassian.com/confkb/confluence-does-not-start-due-to-can-t-find-dependent-libraries-error-972347588.html

LarryBrock
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 15, 2019

Congratulations and great work @Bruno Costa - "doing it the hard way" should get you bonus swag!!!

Like Bruno Costa likes this

Comment

Log in or Sign up to comment