It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

Incorrect Vietnamese encoding in customer portal when page reloading

Hello,

I am getting a weird error with customer portal(only this page) Jira Service Desk

At the first time loading page, everything is OK, Vietnamese encoding(UTF-8) is correct displaying:

Capture1.PNG

But when I reload page,  Vietnamese encoding(UTF-8) is not correct displaying until I back the home page and reopen requested ticket:

Capture2.PNG

Hope your support to troubleshoot this problem.

Thank you so much!

2 comments

Hi Bảo,

Is this cloud or server? If it is server, what database do you use and what encoding do you use for your database?

Hi Nguyen,

I am using Jira Server Desk Server and H2 database default for it. This problem only happens in customer portal at the second page reloading.

Hi Bao,

Make sure your system encoding is set to UTF-8 by going into Jira Admin > System > System Info

If that one is already correct, stop your Jira application and add this line into your  setenv.sh (or setenv.bat if you are on windows server).

setenv.bat:

set JVM_SUPPORT_RECOMMENDED_ARGS=-Dfile.encoding=utf-8 -Dsun.jnu.encoding=utf-8

setenv.sh

JVM_SUPPORT_RECOMMENDED_ARGS="-Dfile.encoding=utf-8 -Dsun.jnu.encoding=utf-8"

The location of your setenv file is at:

<installation-directory>/bin/setenv.sh

Then start your Jira application up again for the change to apply.

Comment

Log in or Sign up to comment
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you