Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Users unable to see Kanban Board and Roadmap (Jira Software Cloud Free) Edited

I am using the Jira Software Cloud Free version and I have set up a company managed project. I am the only user on my team that is able to see the Kanban Board and Roadmap for my project. The board settings show that the board's location is within the correct project. I suspect I deleted a default group called 'atlassian-addons-project-access' which is listed in the projects permission scheme. The free version does not allow me to edit the permission scheme at the project or system level. I've attempted to recreate that group and put my users in it, but they still did not have access to the kanban board and roadmap - when they try to access the link to the board directly they get an error message stating that the board doesn't have an assigned location and to have the admin assign it to a project or a user. 

Additionally I have created a filter for this board however the filter is set to private and it will not let me update it to to have project access by all roles, looks like it's going to work, then just shows the denied icon when attempting to save. 

I've also tried adding my users to a group that grants project admin access, but even after I do that the same users still do not see the Kanban Board or Roadmap. 

I have a separate company managed project in our application which has an agile board and all of my users can see that one just fine. I've scoured Jira Software documentation and community forum and I'm at a loss for what to do. 

Help before I cave and upgrade to the paid version :)image_2021_06_25T14_51_17_673Z.png

Screenshot 2021-06-25 114008.png

3 answers

1 accepted

0 votes
Answer accepted

Hello @Lindsey Watkins,

Thank you for reaching out to Community and for sharing the details.

Testing on my local site, if the filter is set to private, the board will show as private as well and users won’t be able to access it, but then just by changing the permission of the filter, it worked normally.

On a Free site, anyone added to Jira will be an administrator, so the only restriction, in this case, might be the filter.

Can you please go to Search > Boards and confirm if the board shows the location? 

This page shows all the boards, their admin, and their location.

Screen Shot 2021-07-14 at 17.52.24.png

Regarding the issue when trying to change the permission of the filter, can you please try doing that using another browser or incognito mode?

Also, it’s important to disable the extensions on the browser, some of them block Jira features from working correctly, so if possible, disable and try to change the filter permission again.

If the issue persists, open the developer tools but then check the Network tab, click on the error (the 409 error can be ignored), and check the Response tab. It will show status and a message. 

Kind regards,
Angélica

Hi @Angélica Luz

I have confirmed that my board is in the correct location. See attached image. 

I have opened a google chrome incognito tab and disabled all extensions. I am still unable to edit my filter for my board. 

I've opened the developer tools, networks tab. I do not understand where to 'click on the issue and check the response tab'. Here is what I see. Can you guide me to the correct area of the developer tools to get you what you need?

I'm also happy to jump on a remote session so that you can troubleshoot the issue with me if that is a possibility.

board_location.pngdeveloper_tools_console.png

Like Angélica Luz likes this

Ok in Edge I was able to find the error message in the response you are looking for. The error is 10003 and the error message is {"errorMessages":[],"errors":{"shares":"You do not have permission to share. All shares are invalid.","shares_delegated":"The user 'Lindsey Watkins' does not have permission to share. The owner has not been changed."}}. 

A summary of my Atlassian Admin User Group permissions is attached. Under 'Atlassian Product Admin' I have the product 'Jira Administration', under 'Atlassian Super Admin' I have the products 'Jira Software' and 'Jira Administration' and under 'site-admins' I have the product 'confluence'. 

When I navigate to Jira Software > Settings > System > Admin Helper > Permission helper. I cannot select my name or email in the 'user' list to check my own permissions. 

Please let me know what else I should check @Angélica Luz

atlassian_admin_user.pngsoftware_permission_helper.png

Like Angélica Luz likes this

Thank you for testing and for sharing the error message, @Lindsey Watkins.

This error is related to the global permission “Share dashboards and filters.

There is a known bug related to this issue:

Please, go to Cog icon > System > Global permissions.

Then, grant the permission "Share dashboards and filters" for the necessary groups, like site-admins, administrators, jira-administrators.

Screen Shot 2021-07-15 at 10.10.09.png

Please, take your time to test and let us know how it goes.

@Angélica Luz unfortunately when I attempt to grant the 'share dashboards and filters' option using the 'global permissions' I am unable to select any group besides 'public'. I have several groups (see below) in my Atlassian admin > groups. 

I'm not seeing any actionable error messages when using the developer tools on the group selector on the 'global permission' page. The two errors don't have any response.

Please let me know what to try next.

Atlassian_Groups.pngpermission_group_selector.pnggroup_error1.pnggroup_error2.png

It seems that all the global permissions are empty, including the “Browse users and groups” and I was able to replicate the issue here.

The steps to fix are:

Grant “Browse users and groups” permission to “Public”. This option will “unlock” the ability to select the groups, so don’t worry, after you grant this permission, you will be able to select the other groups and then, remove the permission to “Public”.

After selecting “Public” for this permission, you will see that the groups will appear on the drop-down, so grant the permission to site-admins, and then remove the “Public”. After that, grant the permission to site-admins (and other groups if necessary) but not only for the “Share dashboards and filters”, but all of the permissions listed on the "Grant" drop-down field.

I recorded a simple video showing the steps:

This worked!!!! Thank you @Angélica Luz 

Like Angélica Luz likes this
Daniel Ebers Community Leader Jul 18, 2021

Thanks for helping, @Angélica Luz - that was a tough one!
Happy that it works now, @Lindsey Watkins 
You both have a great week!

Like Angélica Luz likes this

Hello @Lindsey Watkins 

Welcome to the community.

The first error message says the board doesn't have a location. Have you tried setting that? Start by fixing that.

https://support.atlassian.com/jira-software-cloud/docs/change-the-location-of-a-board/

Then try sharing the filter again.

Also, try sharing another filter to see if that particular sharing problem is affecting all filter shares or just that one filter share.

The 'atlassian-addons-project-access' is not a group to which actual users should be added. It is the group that is used to grant access to projects for Marketplace apps. The deletion of that group should not make a difference in your users' ability to access the board, but might affect Marketplace apps if you try to add any at a future date.

Hi @Trudy Claspill 

Thanks for the quick reply. 

I navigated to my boards settings again and changed it's location to my personal workspace, then I set it back to the correct project location. That did not resolve the issue. 

I created a new filter and attempted to share it but the same issue is happening when I attempt to save - shows that a PUT request to ../rest/api/3/filter/10004 is returning a 400 error. 

Thanks for the information on that group. Let me know if you have any other suggestions. 

Like Henri Seymour likes this
0 votes
Daniel Ebers Community Leader Jul 02, 2021

Hi @Lindsey Watkins

thanks for your detailed description and welcome to Atlassian Community. I understand you are not able to share filters, supposedly after having the group 'atlassian-addons-project-access' deleted - however, not sure if there is any correlation like Trudy also mentioned.

Do you still see the error when trying to share a filter? If so, I could try to escalate to Atlassian - on a Free plan this is normally not a direct option but there seems to be no way to further inspect as we, as voluntarily helpers in Community, do not have any access to your Cloud site.

Please do let me know if you want Atlassian support having a look over the situation.

Thanks in advance!
Regards,
Daniel

Hi @Daniel Ebers

I do not see any visible error. My filter for my project is currently set to private. When I edit this filter so that it is shared by the project > (selected the correct project) > All roles, then select add, then select save, nothing happens. 

When inspecting this page I see several failed resources and 400 errors in the console along with many warnings. See attached.

I'd love to escalate this to Atlassian support, but I don't know how to do that since I'm on the free plan - can you help?

jira_console_errors.png

Daniel Ebers Community Leader Jul 11, 2021

Sure, @Lindsey Watkins - I will try to bring Atlassian Support in, I am sorry you still cannot share the filter.
Please wait a day or two for help - in case you will not hear back kindly post an update here.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
TAGS
Community showcase
Published in Jira

⏰ Day in the life of a Jira Admin!

Hello Community! We thoroughly enjoyed this just-for-fun conversation in the Jira Admin Group about what it's like to be a Jira Admin. For #JiraJuly, our talented designers created these graphics t...

669 views 2 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you