Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,281
Community Members
 
Community Events
176
Community Groups

Unable to connect Slack to Jira Cloud

Hi,

 

Using the Jira Cloud Slack App, I'm unable to connect a channel to a project.

 

- I have admin access to both the Slack workspace (Owner role) and the Atlassian Site (Org & Site admin)

- The bot appears in the list of Apps in the Slack sidebar

- I can invoke the `/jira connect` command, and the bot displays the drop-down menus

- When I select my Jira site from the dropdown, the bot just displays the message "Something went wrong! Please try again later."

- There's no sign of the Slack integration anywhere in Atlassian/Jira Cloud

 

I have uninstalled and re-installed the app multiple times.

 

I was able to connect a channel to a project in a test Atlassian site, so it definitely does work under some circumstances - I'm assuming some kind of permissions error somewhere in my primary Atlassian org/site, but I'm unsure where to check.

Does anyone know what permission settings are required for Slack to connect correctly?

 

Thanks,

Douglas

2 answers

Hi there, 

 

I'm running into exactly the same issue as Daniel was at the beginning of this thread. I have taken the steps recommended, but when I go to enable the toggle, it says "Slack integration error: something went wrong while getting instance info"

My coworkers are getting the same errors. I have tried unistalling and reinstalling - no difference. 

Would love to hear if there's a fix for this issue. 

Stephanie

Hola Stephanie!

Hace un par de meses me ocurrió lo mismo, con el tiempo se soluciono pero descubrí que fue justo cuando cambio el plan de Atlassian de Gratis a la versión Paga, quizás sea algún tipo de limitante allí.

Saludos!

Daniel Eads Atlassian Team Jan 31, 2022

Hi @Stephanie Evans , welcome to the Community!

It looks like a teammate has already opened a support case about this issue with your site. You should get email updates about the case as it progresses.

For others who may be experiencing this issue with the Slack integration throwing an error even on the configuration page, please open a case with Atlassian Support: support.atlassian.com/contact . We will need to take some action on your site which must be completed by Support, not just a Site Admin.

Thanks,
Daniel Eads | Atlassian Support 

Like Aaron Vo likes this
0 votes
Daniel Eads Atlassian Team Jun 30, 2020

Hey Douglas, welcome to the Community!

There's a toggle for the app in Jira that can disable the app, even if it's listed as installed in the Manage Apps screen.

You can get there either by appending this URL to the end of your instance URL (e.g. https://<yoursite>.atlassian.net/plugins/servlet/ac/jira-slack-integration/addon-config-page )

/plugins/servlet/ac/jira-slack-integration/addon-config-page 

Or by navigating there through the web UI:

  1. Go to the Manage Apps page in Jira administration
  2. Change the dropdown from "User installed" to "System"
  3. Filter/Search for "Slack"
  4. Expand the Slack app and click the Configure button

 

On that page, you'll see a toggle to flip the integration On or Off - example of it off here:

image.png

 

What you want to see is the toggle enabled - you can simply click it to enable it:

image.png

Give that a check! If it's already on, we can continue troubleshooting from there.

Cheers,
Daniel

Hi Daniel,

 

Thanks for your answer!

I've checked, the app doesn't appear in the list and when I go directly to the URL I get an error.

Is there an installation step that I missed? 

 

Douglas

Daniel Eads Atlassian Team Jul 10, 2020

Hey Douglas,

Thanks for checking that out. I've checked the two sites associated with the Atlassian account you used to post here on Community and both seem to report that the Slack integration app is installed. Would you be able to confirm which site is giving you trouble? I'd like to have our team dig into the application logs further.

Thanks!
Daniel

Hi Daniel,

 

I left the integration for a couple of days and then re-attempted the install process from the Slack page and for some reason it worked.

 

I was then able to access the page you mentioned and check that the settings were correct.

 

Thanks for your help!

Douglas

I come across the exact same problem...
Any solution from support?

Daniel Eads Atlassian Team Jan 25, 2021

Hi @Robin Spalthoff , welcome!

Over the last few days we've seen an uptick in errors on our backend when certain actions occur with the Slack integration. Earlier today our team made a change and we observed an immediate drop in that rate. I would suggest giving it a try again now - hopefully any issue you encountered was corrected with that fix.

If you still are having issues, let me know and we'll open a new question to track what you're seeing.

Thanks!
Daniel | Atlassian Support

Hi,

I have the same problem with the slack plugin and in my account I have two sites actives that i am in process to migrate to only one, is it the problem? or Can you help me please?

 

Thanks!

Cesar

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events