Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,572
Community Members
 
Community Events
176
Community Groups

Resolution field missing on the issue layout

I have enabled the "resolution" field on every related config page, but still can't see this field on my new issue view as shown below. Below is my config as well.1.png2.png3.png4.png5.png

 

2 answers

2 accepted

3 votes
Answer accepted
Jack Brickey Community Leader Feb 17, 2020

You probably have a post function that is overriding the chosen value. Edit the workflow and open the transition to done and check post functions. In the new issue view the resolution will always be there by default. 

Thanks Jack!

It was priceless hint. Removed the default "set resolution to done" post function from my workflow and it's working as expected now.

Regards

Like Jack Brickey likes this

Where do I find this post function. For me, the resolution field shows in some transitions and not in others. For example when I want to Mark an issue as Obsolete when in Backlog stage itself, I don't see the resolution field. I see it in some other statuses though

Like Vanessa likes this

We're 1.5 years on from the last comment so you've probably moved past this issue but for those, like myself, that are still hitting this.

New workflows don't have it set as default like the Jira one.

'Set Resolution to Done' can be found in the Add post function option under Update Issue Field - it's the default in the dropdown from there.

0 votes
Answer accepted

Yeah... I had to ask to find the answer for myself. Resolution is shown on the issue view. Not sure why there is no such on the issue layout, but it's not a problem. The problem I really faced is that my "resolution transition" forces that value to "Done" instead of value specified by user.

I'm not sure how to delete this post now.

Hi!

 

I am a little confused by this thread. I have the exact same problem you described initially: Resolution field does not appear on the Issue layout view. I tried Editing the workflow as mentioned but encountered that the workflow I am using is the default and has a message that reads "This workflow is managed internally by Jira Software. Do not manually modify this workflow." and I could not figure out a way to create my own so that I could edit it.

How were you able to make "Resolution" field show up on issue layout?

Like Tanwa Arewa likes this

Have the same issue 

You are using a read-only workflow scheme. Go to Project Settings > Workflow Schemes. Copy the workflow scheme and make it the active workflow scheme of your project. Jira will then allow you to edit the scheme.

Like Tanwa Arewa likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events