Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,360
Community Members
 
Community Events
176
Community Groups

How to specify a specific Issue Type during CSV Import

Atlassian provides this help on CSV import.  But HOW do you actually specify in the CSV file you want the upload to create a specific Issue Type?

 

Issue Type

If not specified in your CSV file, imported issues will be given the default (i.e. first) Issue Type as specified in your Jira site.

2 answers

1 accepted

5 votes
Answer accepted

Hi,

You can just add a column to your csv where you have the issue type.

While importing, you can then map that column to the issue type. Make sure to check the checkbox for mapping the values. Then you can select which value in that column should be mapped to which issue types. 

Hi,

This sounds promising but it's just not working. As can be seen in the screenshot below, we're not presented with Issue Type as a mapping target. 

The file importer is recognizing the raw data but we're unable to map it to anything. 

 

Jira Mapping.png

For what it's worth, we're using a very simple file and have tried different combinations of recommendations from the article below to no avail. 

https://confluence.atlassian.com/jiracoreserver0811/working-in-a-project/working-with-issues/creating-issues-and-sub-tasks/creating-issues-using-the-csv-importer

Sample Data

Summary, IssueType, Description
Epic Summary, epic, Epic Description
Bug Summary, bug, Bug Description
Task Summary, task, Task Description

We have tried with and without a default Issue Type. It successfully creates 3x the default when one is specified or 3x the first issue type in the scheme when the default is set to None. 

 

Using Jira v8.13.10

Hello, did you ever resolve this issue of Issue Type not being presented? I am having this same problem, where I cannot map to Issue Type.


Thanks!

Echoing that although it is the accepted answer, it doesn't work be issue type doesn't appear as a field that can be mapped to.

using IssueType as a csv column header will reveal the "Issue Type" field mapping.  Not great behavior, but it works.

I had to include 'Issue Type' in all the Create screens for the issues that you're trying to import

@Joshua Sims I had to do the same, but like Will said, it works! :)

The only way I have found to resolve this is to have a project user with "Administrator" level status do the import from the System settings using the "External System Import" feature.

If you are not able to get Admin access to the project, then your import will be limited to the fields available in the drop down menus during field mapping.

Assuming you can get elevated account access, you would:

1. Login and go to the settings icon in the upper right and select "System".

Screen Shot 2022-03-30 at 7.43.12 PM.png

2. Select the "External System Import" option from the left navigation.

Screen Shot 2022-03-30 at 7.43.34 PM.png

3. Select "CSV" from the import formats.

Screen Shot 2022-03-30 at 7.43.48 PM.png

4. Proceed to completing the import as usual. You will have tons more field options to choose from, so use the combo box to find the field name you need. "Issue Type" should be one of these.

You will know that you are in the admin version of the import because you will see the "Advanced" options on the first screen.

Screen Shot 2022-03-30 at 7.44.08 PM.png

Once you have a tested, working import, you can save the configuration at the end of the setup. This can be used by checking the box on the first step of the import to use an existing configuration file. You won't need to re-map the fields again. It is useful if repeating the same import process with different data.

Hope this helps!

Hey thanks Neil! That has resolved our issue also. Do you know if Atlassian have a fix in the pipeline?

I don't necessarily know if this needs a "fix" other than a different type of task access that would include import as an action that a specific role could perform. Right now only Administrator level has this access.

It is a delicate situation because you don't want just anyone doing these types of mass imports. The solution, in my mind, would be to have more fine-grained role support, but that doesn't seem to exist right now.

I'm not sure if that is in the Atlassian roadmap anywhere.

I'm a System Administrator and I still cannot do it from a Project, that I have full access to! I can, however, do it from the System area, as you suggested, so thanks for the tip. Ordinarily, we would want Project Admins with extended privileges to be able to do this by themselves, so holding out for a fix! 

Like Matthaus Lomberg likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events