Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automations "can not find configured field" suddenly

Hello,

My automations that have worked for 6 months now have suddenly started returning errors this week.  The issue condition in the audit log is "Could not find your configured field, it may have been deleted?".  The check to see if the field is empty and then set a value if that is the case, so very simple. 

However the field is still there and functioning normally.  I tried deleting and remaking that step of the automation, but it started failing again the next day.   This has started to happen with multiple custom fields of different types - drop down, paragraph, and short text.  Checklist type custom fields do not seem to be affected.

Has anyone else been having trouble?  I'm guessing some internal update has done this.

4 answers

3 accepted

2 votes
Answer accepted
Guilhem Dupuy Community Leader Feb 26, 2021

Hello @Erin Blomert ,

I know that such an error can be returned when the name of the custom field is updated by an Admin; now if no Admin is regularly renaming custom field this shouldn't happen.

Another possible explanation could be with your Atlassian licence payment; if you're late on your licence renewal it might first cause some unexpected errors like the one you are facing, which are followed by the sudden loss of access to your instance afterwards, you could check that too !

@Guilhem Dupuy  The field was definitely not updated by an Admin.  I can't imagine our payments are late either.  Very strange...

 

Edit: No payment issues.  

 

I can't seem to fix the error, even if I remake the automation

0 votes
Answer accepted

@Bill Sheboy   @Guilhem Dupuy 

 

Thanks for your help trying to figure this out.  I put off sending in a ticket for another day, and the issue has mysteriously resolved itself with me changing nothing.   I think something behind the scenes changed, and then was fixed.  

Guilhem Dupuy Community Leader Mar 03, 2021

Okay good to hear @Erin Blomert , that was definitely an unexpected error and it's nice to hear that it was resolved so quickly !

Have a good day !

Oddly enough, another field has started failing instead.

 

This one creates a clone task from a service desk task to a software task.  One of the fields it is supposed to transfer over now gives the "could not find configured field" error, and NONE of the values transfer over.  This happens for... about 1/5 executions.  Seemingly randomly. 

 

I'm hoping that it will go away by itself too.

Hi @Erin Blomert 

Without seeing details of your rule that is failing, I offer two suggestions:

1) If this is using a Created Issue trigger, there could be a timing issue with data availability.  Those can sometimes be addressed with a Re-fetch action.  The "could not find configured field" message is puzzling though, so...

b) Perhaps something is glitched in the field configurations for your instance.  I encourage to you submit a support ticket to Atlassian to see if they notice something the community isn't: https://support.atlassian.com/contact/#/

Best regards,

Bill

0 votes
Answer accepted

Hi @Erin Blomert 

Would you please provide an image of an example rule you see failing?  That may provide some context for the community to help you.  Thanks!

We noted an open defect related to the behavior of JQL and IS EMPTY, so I wonder if the work on that issue is cause problems.  (For that defect, a field which had a value and was cleared cannot match IS EMPTY; Jira is making the technical distinction between BLANK and EMPTY.)


Best regards,

Bill

Hi Bill, I was indeed using "IS EMPTY".  In fact, all my rules that have failed are using "IS EMPTY".  here's the portion of one rule that is causing the problems:

 

image.pngimage.png

Gotcha... What type of field are you testing for IS EMPTY?

As a work-around for text fields, we are checking length for zero.  For example for Description: {{issue.description.length()}}

Your workaround would work for the text fields I am having trouble with!  I can set that up.  Thanks.

 

The field in the example above is actually a drop down list, so I'm not sure how to work that one.   It's kind of ridiculous for them to all stop working one day.

I'm also not sure if it's not finding it when it does the condition, or if it's not finding it when it actually tries to input the value.  If the field is not empty, it actually seems to fail the conditional correctly and the automation has no errors.

For a list field, I have not noticed those having problems with IS EMPTY tests.  If you are, you can try the list functions.  For example for fixVersion checking to zero for {{issue.fixVersion.size}}

Debugging automation rules can be tricky; please consider adding actions to log to the audit log.  That can show you values as you progress and reveal why conditions do not work as expected.

For more debugging ideas, please see this article:

https://support.atlassian.com/jira-software-cloud/docs/debug-a-rule/

Thanks,

Bill

@Bill Sheboy 

 

It's not a "list", it's a drop down where you select one of two items. I may have stated that incorrectly!  I will try adding more debug statements, but my problem remains that the automation is suddenly not recognizing that the field exists, even after a remake.

No worries, and the drop-down fields are "list" fields once you get inside a rule.

At this point, I recommend you submit a support ticket to Atlassian as they may see something behind the scenes that is causing this.  Here is the link to do that:

https://support.atlassian.com/contact/#/

Once you learn more from support, please consider posting back here so others in the community can benefit.  Thanks!

0 votes

It looks like I'm running into this same issue now. Has this been fixed for you @Erin Blomert ?

This is my query where IS EMPTY seems to be bugging out

 

Screen Shot 2021-08-02 at 10.55.35 AM.png

Hi @Mia Dinh -- Welcome to the Atlassian Community!

Please consider creating a new question and linking to other ones. That will help other people find the question more easily and allow you to decide when it is resolved/accepted. Thanks!

For your post, you note "my query where IS EMPTY seems to be bugging out".  What are you observing?

Epic Link is a custom field (a built-in one), and there are at least 2 open defects around NOT EMPTY tests.  I wonder if your field had a value, and was then cleared, causing this result.

Best regards,
Bill

@Mia Dinh  Honestly mine just stopped failling after a week or two - I did not end up finding a solution but I would say the bug that was causing the failures must have been resolved in the background.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

635 views 16 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you