Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

email request settings from project cannot connect to mail server

I was setting up jira service desk in our organization server and configured it all. The connection tests were all fine. Then I created a project and for that project, I configured the email request. After filling all fields and saving and authorizing, I was prompted with an error.

We could not connect to your mail server, Something has gone wrong with your request. If symptoms persist contact your System Administrator. Check out our troubleshooting docs for help resolving the issue.

However, the connection to the mail server and its desired port was all fine.

Kindly help us resolve this issue.

2 answers

Hello everyone, You can also try this;

  • Tip 1: Make sure your account credentials or Exchange server name are correct
  • Tip 2: Verify that Outlook is online
  • Tip 3: Make sure that your computer is connected to the network
  • Tip 4: Check your Microsoft Exchange server connection
  • Tip 5: Use SSL to connect Microsoft Exchange server
  • Tip 6: Configure a connection to a proxy server
  • Tip 7: Repair Outlook Account
  • Tip 8: Disabling Extensions
  • Tip 9: Rebuilding Outlook data file
  • Tip 10: Repairing/ Reinstalling Outlook
  • Tip 11: Repair a profile using Stellar Outlook Repair

Hi @Samantha ,

I've tried logging in the outlook account and it works well. Its just that the email request in project is giving the error.

Like Samantha likes this

Hi @F1 System,

Welcome to the Atlassian community.

This depends on what is in the logs and what the specific error is when connecting to the mail server.

Some possibilities include a changed server name, an expired SSL certificate, a firewall change, it just cannot be stated without further information.

Thanks,
Moga

Hello @mogavenasan

We have not changed server name, SSL certificate also hasn't expired and there is no change in firewall. I tried checking logs but there are not relevant log files where such incidents are recorded.

Is there any way to record logs.

It should be in the atlassian-jira.log or atlassian-jira-incoming-mail.log. If you are not seeing anything in those log files, then you can enable DEBUG logging for the incoming mail as per this doc:

image.png 

In my case, there was no logs recorded in atlassian-jira.log. Also the log file atlassian-jira-incoming-mail.log was not there.

I am getting following error. However, I'm able to login to the outlook with same credentials.

2021-02-16 17:44:18,757+0545 ERROR [] Caesium-1-4 ServiceRunner Messaging Error when MailPullerWorker pulls emails from csd@fonepay.com: Logon failure: unknown user name or bad password.
2021-02-16 17:44:46,715+0545 ERROR [] http-nio-8080-exec-16 fonepay 1064x166x1 mm7b9o 10.13.222.1,0:0:0:0:0:0:0:1 /rest/servicedesk/1/servicedesk/admin/email/test Unable to connect to the server at mail.f1soft.com due to the following exception:
javax.mail.AuthenticationFailedException: Logon failure: unknown user name or bad password.
at com.sun.mail.pop3.POP3Store.protocolConnect(POP3Store.java:193) [jakarta.mail-1.6.5-atlassian-2.jar:1.6.5-atlassian-2]
at javax.mail.Service.connect(Service.java:342) [jakarta.mail-1.6.5-atlassian-2.jar:1.6.5-atlassian-2]
at javax.mail.Service.connect(Service.java:222) [jakarta.mail-1.6.5-atlassian-2.jar:1.6.5-atlassian-2]
at javax.mail.Service.connect(Service.java:243) [jakarta.mail-1.6.5-atlassian-2.jar:1.6.5-atlassian-2]
at com.atlassian.jira.internal.mail.processor.feature.channel.connectionverifier.DefaultChannelConnectionVerifier.verifyConnectionDefinition(DefaultChannelConnectionVerifier.java:88) [?:?]
at com.atlassian.jira.internal.mail.processor.feature.channel.connectionverifier.DefaultChannelConnectionVerifier.verifyConnectionDefinition(DefaultChannelConnectionVerifier.java:68) [?:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [?:1.8.0_275]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [?:1.8.0_275]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [?:1.8.0_275]
at java.lang.reflect.Method.invoke(Method.java:498) [?:1.8.0_275]
at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:343) [spring-aop-5.1.18.RELEASE.jar:5.1.18.RELEASE]
at org.eclipse.gemini.blueprint.service.importer.support.internal.aop.ServiceInvoker.doInvoke(ServiceInvoker.java:56) [?:?]
at org.eclipse.gemini.blueprint.service.importer.support.internal.aop.ServiceInvoker.invoke(ServiceInvoker.java:60) [?:?]
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:186) [spring-aop-5.1.18.RELEASE.jar:5.1.18.RELEASE]
at org.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:136) [spring-aop-5.1.18.RELEASE.jar:5.1.18.RELEASE]

Daniel Ebers Community Leader Feb 16, 2021

Just a guess from the outside - but I would probably change the password of the mail account (to one without special characters) and try again.
Assuming there are special characters in password maybe they are preventing authentication (for whatever exactly case...).

Hi @F1 System,

Finally, we have something from the log files!

  1. You can do what Daniel mentioned, change the password to something without special characters.
  2. Check if you need to include domain property into the username as stated in this KB

Hi @Daniel Ebers , I had used password with special characters while setting up the email request and it had worked. But when I'd changed the password of email account, and changed it in the email request as well, that error was notified.

Hi @mogavenasan, the email account is in the domain, but I didn't find the configuration file where to include the information of email domain. Please provide me the path to the location of configuration file.

The configuration is not in any files, it's on the UI. It's the same place where you configure the Incoming Mail server configuration.

@mogavenasan , When I use the same configuration in Incoming Mail configuration, the connection is fine, but when I use it in email request section of project, the error is seen.

Have you tried changing the username on the Incoming Mail configuration to have the domain property and configure the email request?

Yes, I'd tried that as well, but it didn't work.

What's the error in the log files?

The error was same as above in log files.

Apologies, I mentioned the wrong configuration here. We should be focusing on the email channel only:
image.png

The username on this page should be updated. Are you getting the same result in this case? You will need to check with the Mail Server admin if the combination is the Emaill + Password or Username + Password.

Yes, I'd updated the username and password in this section. I can login with the credentials in mail server hosted in our organization but once I update the the password and save and authorize I am prompted with the error. Also the configuration is also not saved.

Hi @mogavenasan ,

I setup jira from scratch again and this time I can change the credentials with no issue. But this time, the email puller is pulling mails from mailbox but ticket is not being generated. Please suggest to fix this.

What do you see under the Jira Administration > Applications > Jira Service Management - Email requests? You should be able to see the connectivity and the processing logs.

Once the email is processed, you will be able to see the processing log. A screenshot of this would be helpful to identify what's going on.

@mogavenasan

Thanks for the information, I checked the processing log and it showed failure or rejected with details signup is not currently available. I changed the signup options for customer, and now email puller is pulling emails.

Like mogavenasan likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Jira Service Management

Submit your Jira Service Management use case and win!

Hi everyone - in case you haven’t heard, we’re hosting the show of the century on November 10th: High Velocity: ITSM World Tour.     This virtual, concert-themed experience...

272 views 1 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you