Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

cannot manage 1 particular add-on , Invalid module key specified

I cannot expand/access/manage an add-on. The error comes from the underlying call to

https://<serverurl>/rest/plugins/1.0/com.onresolve.jira.groovy.groovyrunner-key

This gives a 500 - Invalid module key specified

 

Whatever I do, I cannot seem to fix it. The add-on seems to function ok.

Other endpoints do work:  eg. /rest/plugins/1.0/com.onresolve.jira.groovy.groovyrunner-key/license

 

 

2 answers

Hi Dimitri C, 

 

We have exactly the same problem here. I'm interested if you found a solution to solve this problem.

I finally ended up deleting the plugin in the database directly and manually removing the jar file, and re-install. That was the only way

Thanks for your prompt answer Dimitri C !!

What is the SQL query to remove the plugin in the database?

What about all scripts and custom fields already created? Are they removed as well?

I already tried to remove the jar file and re-upload it but it did not work.

I can't seem to locate it right now, but you can also try via REST;

DELETE /rest/plugins/1.0/${plugin.key}-key

 

no, it doesn't remove the scripts & fields, they'll just error. WHen re-installing the plugin all should be ok again

Ok,

I'll give it a try, 

Thanks a lot for your help!

Hi,

I managed to delete it via REST. I tried to install the latest version from UPM. The installation finished with the same error "invalid module key specified" !

However the addon seems to be installed with the latest version, but it is not manageable, which can be a problem to apply a new license for instance. This issue make me crazy. Let's hope that Adaptavist support will find a way to solve this issue. 

The problem has finally been solved by Adaptavist support in our case. https://productsupport.adaptavist.com/browse/SRPLAT-1442

It came from a Scriptrunner Fragment configured with the Key field empty.

2021-02-05 15_03_15-Fragments.png

 

The version 6.19.0 will contains a fix for this bug. 

Adaptavist released the version 6.19.0 that fix this issue: https://marketplace.atlassian.com/apps/6820/scriptrunner-for-jira?hosting=server&tab=versions

I installed it and it solved the problem

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Jira Service Management

Why upgrade to Jira Service Management Premium?

We often have questions from folks using Jira Service Management about the benefits to using Premium. Check out this video to learn how you can unlock even more value in our Premium plan.  &nb...

170 views 0 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you