Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,183
Community Members
 
Community Events
165
Community Groups

Why isn't automation for Jira loading in the free version?

Automation for Jira loads fine in my company instance of Jira, but in my free-version I'm trying out for home use, it just gives an error. I didn't see any restrictions on automation at a glance in the outline for free version so I was curious if I'm missing something or if it should be working. I've seen other posts where refreshing did the trick, but I've tried three different browsers, including a fresh install, rebooted, and confirmed non-free instances work in the same browser, in and out of incognito mode. Any thoughts? 

 

The error that pops up when it fails to load is:

"An embedded page at automation.codebarrel.io says
An unknown error occurred. Please reload and try again."

2 answers

1 accepted

0 votes
Answer accepted

Hello @Colen Shields ,

Thanks for reaching out and the free platform should still allow you to access and use the automation features and I am not reconizing that error off hand, so we will need to do a bit of troubleshooting to narrow this one down.

But one point first you had noted "I didn't see any restrictions on automation at a glance in the outline for free version" however there are some variations on the plan level associated to avaliable usage for Automation.

The Feature limits between the license levels can be seen in Table in the "Plans and pricing"  page noting that the Free and standard plans have full access to the "Automation (single-project)" levels but have a reduced access level to "Automation (global and multi-project)"  if you select the "Automation (global and multi-project)" text it expands to give additional details on the feature noting:

Automation (global and multi-project)
Set and forget automation rules across multiple projects or your entire organisation. Global automation is the smartest way to scale. Premium users have 1000 global and multi-project rules per paid user per month. Ex: 200 users in Jira Cloud Premium will have 200,000 monthly global/multi-project rules per month. This is pooled across all Jira tools and all users.

Customers on free and standard plans have access to 100 and 500 global and multi-project rules per month respectively. Learn more.

And there is a more detailed breakdown viewable on the differences in the "Jira Cloud plans" documentation at the following link under the "Plans comparison for Jira Software and Core" and the "Plans comparison for Jira Service Desk" expandable sections:

And details on viewing the usage levels on your site can be seen in the article:

Next, a couple questions on the error to help narrow this one down

  1. what is the path you are following when this error is being triggered
    1. i.e. Is this on global level or the project level rules
    2. does it occur only on a specific page or following a certain link / navigation path
  2. Can you check to see if the usage limits are exceeded 
  3. Can you load your browsers developer tools  javascript console and see if there are any additional errors displayed that could indicate other issues causing the failure
  4. Can you grab a screenshot of the behavior

Regards,
Earl

My apologies I didn't respond sooner! It has been a busy month and I didn't see your response.

The rules I was trying to set up were in a single project and the path was just clicking Project Settings>Project Automation in my Service Desk project and it generated that error. I created another test project for ITSM and it had the same issue no matter how I tried to get to automation. 

There were no usage limits being exceeded.

Questions 3 and 4 factor into me using past tense because I just logged in today and it's working as expected, no errors!

0 votes
Florian PEREZ Community Leader Jun 08, 2022

You should try the following solution 

https://confluence.atlassian.com/automation/upgrading-to-automation-for-jira-7-3-1055951956.html 

I experienced the same problem upgrading from 7,2- to 7,3+ and this have fixed my problem

The support helped a lot on this one to be perfectly honnest

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Posted in Jira Service Management

Jira Service Management Documentation Opportunities

Hello everyone, Hope everyone is safe! A few months ago we posted an article sharing all the new articles and documentation that we, the AMER Jira Service Management team created. As mentioned ...

255 views 0 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you