Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

The Discovery tool is unable to connect to the Dell PowerEdge iDRAC9 via SNMP correctly.

三断笛 September 18, 2023

Even after correctly configuring the SNMP connection in the Discovery tool, it consistently fails to establish an SNMP connection to iDRAC9, displaying the error message, "IP Address is reachable but connection wasn't successful, try to check credentials of your SNMP device." However, when I use tools like SNMPwalk or OIDview, the connection works perfectly fine.

I have also attempted configuring SNMPv3 on iDRAC9, and the Discovery tool still presents the same error, while other SNMP tools connect successfully. I have even tried using the Discovery tool to connect to other iDRAC9 devices, but the same error persists.

Interestingly, the Discovery tool can establish SNMP connections to other devices such as printers and switches without any issues. It seems that the problem is specific to connecting to iDRAC9 devices.

Discovery-tool Version:3.1.10

2 answers

0 votes
三断笛 September 19, 2023

Using Wireshark, it was discovered that the Discovery tool uses the SNMP query 1.3.6.1.2.1.1.1.0 to obtain the sysDescr to determine if SNMP can be connected successfully. However, the sysDescr value for iDRAC9 devices is empty. It is recommended to modify the logic for determining SNMP connectivity.

0 votes
三断笛 September 19, 2023

I can successfully connect to iDRAC9 using SharpSnmpLib (version 12.5.1.0 and 12.5.2.0) in C#. It appears that the issue is indeed with the Discovery tool.

I'm looking forward to guidance and assistance. Thank you.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events